Loading screen music

Hi I’m trying to get my loading screen to work and for some reason I cant do it.

What i’ve tried:

I have tried embedding the music from my web server

I have tried embedding the music straight from a youtube video

and i have also tried to Iframe in the youtube video.

All of these methods work in browser but not in game. The only one that gives me any kind of error is when I put in the music straight from my server I get missing plugin, but that is not because I dont have flash on my computer because all other people have it too. Is there a method of doing this that actually works?

This should help you out

I would warn you not to have music though because it can drive players away who dont want to download 10 minutes of playermodels while listening to the owner’s shitty EDM or dubstep.

Do not add music. If theres one thing i hate then its music in loadingscreens. And because hl2.exe reasons i cannot mute my game as the soundmananger doesnt open while joining :v

Mute Awesomium
Leave it muted

If I were you, I would think twice before adding music, but if you must insist, here’s an example:


<iframe width="1" height="1" src="//www.youtube.com/embed/VIDEO_ID_HERE?rel=0&autoplay=1&showinfo=0&controls=0&autohide=1" frameborder="0" allowfullscreen></iframe>

What you probably did wrong was leaving width and height set to 0, it doesn’t work that way. Just embed your url the normal way.

Still not working? This should help you:
https://www.youtube.com/watch?v=SAAjd0RsffA

What about PlayX and stuff though?

Never used it