Loading screen not going away?

So uh, whenever i start a new game and begin loading a map there’s like a 50% chance that the loading screen won’t go away upon completion (regardless of what map i am loading).
I made a thread about this weeks ago yet i’ve had no response nor luck in finding a solution.

I tried bypassing it by redownloading some of the maps were the load failed, yet it seems to be a random issue.
Sure, i could restart Gmod several times and then have it worked but the thing is that at least two maps that i have seems have this problem at all times, which is trobling to say the least.

Today i made a second attempt to bypass it by alt-tabbing which replaced the frozen loading screen with a completely black one instead.
If i use the WASD-keys etc. i can hear my character moving/sprinting/shooting in the background which indicates that it does infact load the map, even though the loading screen freezes upon completion and remains as a static image.

Does anyone at all know what might be causing this? Too many addons? Some graphic issues? Faulty code? Anything?

Anyone? Please?
This is issue is so fucking stupid, what’s even more stupid is that there seems to be nobody who can help me fix it…

Interesting issue. Can you hold alt + ~ to open the console when you’re in game but not seeing the game? I don’t know what would be causing the awesomium process to ‘hold’ onto the viewport but maybe you could try killing the awesomium process through taskman when you get in game?

I’ll have to try that, thanks.

[editline]30th December 2014[/editline]

Okay so, loading screen is still there although the fact that the cursor appeared i can tell that console window opened.
What do you suggest i do?

Update: Backed up my files again before wiping the entire Gmod directory & performing a clean install.

No change besides faste loading times due to all manually installed addons/maps/etc. not being present.
I am starting to suspect that maybe a Workshop addon is causing all this, no idea where to start looking though…

Does removing ALL addons, including workshop ones ( Disable all ) solves the issue? If yes, its an addon. If not, it’s one of your convars. Post your config.cfg.

I disabled all addons, no change. Give me a moment for the config.cfg…

[editline]2nd January 2015[/editline]

CFG

Try entering sv_skyname “” into your console.

[editline]2nd January 2015[/editline]

That is the only thing I found weird about your cfg.

[editline]2nd January 2015[/editline]

When you reinstalled, did you backup and copy your cfg folder back?

Am i supposed to type in something between the "'s?

[editline]2nd January 2015[/editline]

No, i did not back up my .cfg folder.

No. It will probably not solve anything. You should just wipe your cfg folder ( config.cfg will come back automatically from Steam Cloud ) after getting rid of all mounted games and addons and then verify.

Alright, disabled the mounted games. Waiting for the verification to finish.

[editline]2nd January 2015[/editline]

Damn, still doesn’t work.

[editline]2nd January 2015[/editline]

Got anything else up your sleeves Robotboy?

I guess that rules out all possibilities of fixing whatever is causing this…

Can you open the spawnmenu after the loading is done?

Yes but i can’t see it since the loading screen remains.

Have you done a COMPLETE clean install?

Yes, three times.

Including removal and unsubscription of all workshop addons?

Yes.

So, any more ideas? Would replacing my cfg with that of someone else whom can play the game flawlessly help in any way?

I was contacted earlier about this issue, and I was told that this happens on AMD video cards. Can you confirm?