Low fps with a good gaming pc?

I have been wondering why i have low fps in the game, around 40-50 and sometimes even 30! I bought this game yesterday when the whole DDoS thing started. Yesterday evening when dossers went to bed, my game menu and fps got really good! Menu was smooth and game fps was around 80-100 on fantastic. When i woke up it was around 40-50 again. Is this because of the DDoS attack? But some people are saying that their game is running smoothly.

My computer spec’s:

-CPU: AMD Phenom II x4 965BE 3,4Ghz (OC’d to 4,0Ghz)
-CPU(Cooler): Noctua NH-U12P Se2
-GPU: Asus Geforce GTX 760 DirectCU II OC 2Gb GDDR5
-RAM: Corsair XMS3 4x2Gb DDR3
-PCU: Cooler Master 650W GX, ATX-power supply, 80Plus Bronze
-MOBA: MSI 785GM-E51
-HDD: Hitachi 500Gb
-SSD: Kingston SSDnow v300 120Gb

The servers are laggy. This game is in Alpha. Dont expect it to run smoothly. Your computer should be able to handle the FINISHED game, but right now things are laggy.

It hasn’t happened to me, even while the DDoS’ing was occurring… but I’d say It can be a factor of things:

  1. Where you are.

  2. What’s in said area.

  3. How many people are there.

Etc. You get the point. Turning your graphics to the lowest won’t hurt, so try that as well. I sometimes lag in rad town when I walk into a certain building every single time, so it’s possibly your location? Considering your specs are more than enough to play Rust decently.

Well the thing is that even if i am somewhere in the “wilderness” it lags the same way if i would be in rad town. The server where i play on has 5 to 10 player on! I have turned my graphics to the lowest but it just gives me a frame or two. : /

And just to get you all more cleared, i play bioshock infinite and borderlands 2 on ultra and physix on ultra aswell.

Have you updated your drivers lately? What about disabling the grass in-game? It makes no noticeable difference for me, but it may possibly do such for you (grass.on false in console). That’s all I can think of for now. Try looking into it more, or wait for someone else who may be able to help you further :slight_smile:

I’d say your issues are more of an optimization thing. Remember, you are playing an Alpha.

I doubt Nvidia or AMD are currently spending any time or effort on their drivers to suit this game either as it’s unfinished.
If FPS numbers are really all that matter to you (anything over 30 will be smooth) Then lower your settings. You wont see any difference between 60FPS and say 120FPS unless you have a 120hz Monitor anyways. So you are really wasting frames.

I think i have? Have to check… But yea the grass is disabled, again helps a frame or two…

You can do the following : Press f1 while on a server and typing into the console “grass.on false”

Another thing you can connect to the server you want to play on, press F1 and write down the IP. Then restart the game (And make sure you do not open the server browser), press F1 again and type “net.connect (IP here)”

Disable that grass son, does wonders.

Oh my goodness! That worked :smiley: I pressed F1 and typed the ip and now it’s more than smooth. Wow… Thank you good sir! :slight_smile: