Lua addons don't work for my server?

What doesn’t work?

So, pretty much nothing works that I add from Google except from workshop… I was trying to add a lua addon called Chat Filter, so I found one, tried and adding it and my server reacted like I added nothing. I am guessing you have to put the file somewhere else around the server files, I am hosting the server from Nitrous Networks btw. I tried adding this one: http://forum.facepunch.com/showthread.php?t=921946 <–

Sorry for being a nuub at coding/developing but I am learning step by step at least. I was guessing that I had to put some part of that addon in to my /garrysmod/lua/autorun but I don’t know exactly what. I hope someone can understand and help me with this problem, Thank you!

Well, in that addon’s zip file there’s a folder called ‘lua’ - if you copy and paste that into



C:\Program Files (x86)\Steam\SteamApps\common\GarrysMod\garrysmod


Then click ‘merge’ or whatever that button says (since there should already be a folder called ‘lua’ in that file path) then it should work

That addon has pretty old code though so it might have some problems with it

[editline]22nd March 2016[/editline]

Oh yeah, and the folder called ‘lua’ is in the first and only folder in the zip file - I don’t think any of the other files are actually needed

Wait, on steamapps on my computer or the website I host server off?

Well, I don’t really know anything about servers, but I think it’d have to be put on the website you host it off, if you put it on your computer it’d only work for you in singleplayer, and it wouldn’t work on the server - but you should probably wait because someone who knows something about servers will probably correct me about where to put it exactly

Okay but you still helped me a little, Cheers bud.

If you open the zip file, there should be a folder called ChatFilter, just drop that into your servers addons folder and it should work, but like MPan said, it was made in 2010.

It can’t be just that easy, I add it to my addons restart server, run FAST DL and it doesn’t find any part of that addon but so I still join server, type chatfilter in the console and it is a unknown command. Fine, I am not even that bothered about the chatfilter, I will find another one but then I try and add other commands that react the same, as if I didn’t do anything.

[editline]22nd March 2016[/editline]

BTW guys, the only addons that do something are the ones I get of workshop with “Gmad Extractor” but I guess they only work because I have to do “resource.AddWorkshop(“5471235”)” <- Example… hope someone knows what I mean, I can’t explain that good because I am new on coding/lua…

I need help :frowning: I tried making my own lua addon exactly the same as it was on the video but when I put on my server its like isn’t not on.

so?

WELL

This doesn’t require fast dl… so it’s obviously old and broken.