Lua Cache Couldnt be downloaded, Server is misconfigured, everytime I join the darkrp server

Okay, for the last couple days I have been having 2 big problems joining a server, just one server! Now, I have talked to the owner, i am admin on the server and the owner doesnt think its his cache or the servers fault I cant join. He also said no one else is having the problem but me! He deleted his cache once and restarted the server, but I had the problem still (Problem 2). :frowning:

1st Problem: Upon Joining the Dark RP v 2.4.1 and Rp Downtown V2, Garrysmod will cancel out with a HL2RP.exe is not responding. The only fix I have found out is too load up the map before joining the server, is there any other way to fix this officially?

2nd Problem: This is the worst problem I have, and I dont know anyone who has this problem, I have also checked online. Only 1 other thread contained the problem, but it wasnt answered correctly. Upon Joining The Dark RP server I will get RED TEXT ON THE TOP RIGHT saying “Lua Cache couldnt be downloaded, server is misconfigured” and I check the console and see text spamming “gamemode error” stuff like that, It also wont let me do ANYTHING in the server besides walk around, jump, and stuff like that, no f4 menu or tab only phys gun and grav gun. Please someone Help me!

Facts: I have reinstalled gmod, deleted gmod folder, reupdated cache, defragged cache, validified cache, nothing seems to work, I ALSO have only one addon, and that is wiremod, thats IT! And I am using Dx Level 9 or watever its called. I have no idea why this is happening to me?

The TTT server I play on was just updated and when I join it I’m getting the “Lua cache couldn’t be downloaded. Server is misconfigured.” error. Everyone else seems to be able to play it without any problems. I tried reinstalling Garry’s Mod, but it still has the same error. I too can’t find an answer so far :\

The error is caused when somebody has sv_downloadurl set and nothing in it. The lua cache must be included in the fastdl, or else that error will occur. typing
sv_downloadurl " "
should fix this.
also: remove sv_downloadurl from your server.cfg and or autoexec.cfg