Lua cache errors

Hi, I’m trying to run a DarkRP server FastDL but the good ol’ cache error keeps coming up and no other forum is any help whatsoever so heres my current situation:
I have copied and pasted the .dua file to the webserver, didn’t work
I have symlinked the .dua file to the webserver, didn’t work
I have written the resource.AddFile to it, didn’t work
In my server.cfg I have this:
sv_allowupload
sv_allowdownload
sv_downloadurl “http://eehnfjbfg.ehgjn.net/
I have tried it without the trailing “/” and without the “http://” didn’t work!
and now I’m at a loss, the only thing I can think of now is permissions for everyone to be able to read and write it, but I’m not confident that will work.
PLEASE HALP D:

Moved everything in the cache directory to the cache folder on fastdl?

There should be a 1 next to sv_allowdownload

Actually. I cannot connect to the site.

Yeah it is one file, and it was some gibberish the real site wouldnt work anyway not done the permissions yet, giving a last chance to resource.AddFile ( i have re-written it) and there are ones, just didn’t type them in on the post (obviously)

Ah! You don’t need to do resource.addfile on caches.

Type sv_downloadurl in console. What does it output?

it outputs: “sv_downloadurl” = “http://gmod.minecraftia.net/rp/garrysmod” ( def. “”)
replicated

  • Location from which clients can download missing files

The configuration is definitely okay. Are the permissions for the cache set to for World?

I don’t think so, I’ll do it now in FileZilla

EDIT: Okay I set the permissions so everyone can read, write and execute (777) trying now

EDIT 2: W0000000000000t It worked, thanks very much :slight_smile:

Too easy. They should be at least 664 or 644 or something like that.