Lua ClientSide Errors

System hardware specs

  • AMD Athlon 64 Processor 3200+
  • 2.5GB RAM
  • NVIDIA GeForce 8500 GT
  • MS Windows XP Professional SP3

The addons that I have have put into the addons folder don’t seem to work in Singleplayer, but that isn’t my concern.

My real concern is these Clientside errors that constantly spam my screen. I get the errors:


ERROR: GAMEMODE:'HUDPaint' Failed: [DarkRP\gamemode\cl_init.lua:441] attempt to index upvalue 'HUDHeight' (a nil value)"

It’s like that for singleplayer and multiplayer but my cousin sees everything just fine in our server. I’m thinking it has to do with Windows XP itself for not loading any of the addons I have installed. Come to think of it, it really only loads anything it has downloaded in-game. Images of Singleplayer:

Image of multiplayer:

Get the DarkRP SVN.

Thanks, but I tried that. In the singleplayer pictures, it says “gamemodes/sandbox” so I know it isn’t just DarkRP.

But the error is a DarkRP’ish error.

[lua]
ERROR: GAMEMODE:‘HUDPaint’ Failed: DarkRP\gamemode\cl_init.lua
[/lua]

I just deleted my gamemodes folder in my Garrysmod/garrysmod directory and re-installed the folder from Steam. Let me see if this works.

Edit:
I checked my Gamemodes folder before I deleted it. It had nothing:P Wow. I feel dumb.

Double Edit:
Alright. That didn’t work. I’m also getting


[weapons\weapon_mad_base_sniper\cl_init.lua:77] attempt to index global 'cl_crosshair_t' (a nil value)

Do you have MadCow’s weapon pack?

Yes/no. I have it in our FastDL when I joined the first time and it didn’t woirk. I could still see the weapons themselves though.

I just decided to go with deleting the whole garrysmod folder and re-validating and installing the whole game again. That fixed it although now I can’t hear most sounds from other source games. Oh well. At least I can see normally in DarkRP:P Thanks anyways.

Anytime.