Lua error for a server addon?

Ok so I am trying to get levels for my server and this one creates lua errors http://www.garrysmod.org/downloads/?a=view&id=128976

This is from Garrys Mod 12, So that is why its creating Lua Errors, Some GMOD 12 Addons no longer work - Or even exist for that matter.

While some do work and exist, That is because they were updated to run on Garrys mod 13.

hint of advice, anything you find on that website is probably outdated. either look around on recent threads here on facepunch, or use workshop