Lua Error - Something went horribly wrong! "out of memory"

This is happening while joining a server I’ve been playing for a while. I’m running an Asus ROG g751 - Windows 10 - Intel Core i7 - Nvidia Geforce GTX 965m. I have 16gb of ram and barely any of it is being used currently. I’ve done the whole 9 yards. Remove addons from folder, unsubscribe, try without addons. I’ve reset my PC, later on completely removed Gmod from my PC then reinstalled. I also tried changing Heapsize and all kinds of startup line stuff. Nothing has worked. It just happened out of nowhere after playing on the server smoothly without a problem. All the sudden I crash and it says CDML Out of memory. I reset my pc, tried again and once it gets to requesting client info I get a Lua error as show in title, and have been since. I’ve googled it am million times and I get the same “fixes” everywhere. And obviously they aren’t fixes. Oh yeah and I already verified my game cache so you can check that off. Any tips and answers would be greatly appreciated. Thanks!

Reinstall your game.