Lua errors/Red error messages while using SWEPs.

System hardware specs

  • Processor: Intel T2130 @ 1,8 GHZ Dual Core.
  • RAM: 2048 MB
  • Graphics Card: ATI Radeon Xpress 1200 (Up2date Drivers)
  • Operating System: Windows XP SP 3
    [gmod runs pretty smooth on my system]

Addons:
SVN
-Wiremod
-ADV Duplicator
-GDCW
-PHX
-PlayX
-NPCgun

Downloaded
-DearSisterv2
-Halo SWEPs
-Combine NPCs
-madkilmw2
-All WWII DOD SWEPS V2

Everytime when I use any of these SWEPs, I get loads of Lua errors/red error messages if I try to use one of the above mentioned SWEPs. The only pack that I’m able to use is the “All WWII DOD SWEPS V2” pack.
I’ve cleaned my gmod, uninstalled it, reinstalled it over 2 times now and it’s still not working… any idea?
Am I missing some Addons for the SWEPs?

the errors would be useful

Indeed. We can’t really help without seeing the errors.

There are these red errors popping up when I’m using the SWEPs.

I guess something is missing, but I don’t have any clue what.
I’ve downloaded all what is needed for this stuff… well I think so.

We need to know what the errors say, copy them and past them here.

I think he means error models.
You lack the necessary content for those addons.

Well… then I’ll have to find the missing content… thanks for trying to help me.

if you are getting errors try buying CSS, HL2+epesodes DODS and all valve games as you are missing the contend reqired i recomend the valve complete pac as it is only 25£ in the steam sale at the moment.