Lua errors when a player spawns into the server.

I recently had to wipe my server due to some “individuals” hacking into the RCON, banning and demoting my admins etc. But I’ve re-opened the server and since then whenever someone has spawned into the server it would appear with the below error:

[ERROR] lua/includes/extensions/table.lua:51: bad argument #1 to ‘pairs’ (table expected, got nil)

  1. pairs - [C]:-1
  2. Empty - lua/includes/extensions/table.lua:51
    3. fn - addons/ulx/lua/ulx/modules/cl/xgui_client.lua:428
    4. func - addons/ulib/lua/ulib/client/cl_util.lua:22
    5. unknown - lua/includes/modules/net.lua:32

This didn’t happen before but has randomly appeared now.

http://pastebin.com/UNHZa1fC – table.lua
http://pastebin.com/h8xZCZTE – xgui_client.lua
http://pastebin.com/xXmma2MN – cl_util.lua
http://pastebin.com/EgFvW9g0 – net.lua

– All of the files above featured in the error, better overly prepared than not at all.

So any suggestions/help are very welcome. Thanks.

-snip-

to prevent dunked.asia/p100 skids from downloading ur server.cfg with a requestfile extension bypass, do these things:
make sure sv_allowcslua and sv_allowdownload are both set to 0, and remove rcon_password from server.cfg

-snip-

Not wiping the server again to fix a simple lua error.
And what do you mean by “You haven’t fixed the problem”?

wtf are you talking about? changing rcon pass wont do anything, they are DOWNLOADING your server.cfg, where your rcon pass is located

-snip-