Lua Panic: Not enough memory.

I’ve been getting this error for quite a while now. It only effects one server that I know of.

I’ve tried the following:

Deleting my Addons
Reinstalling Garry’s Mod
Following steps in previous threads (such as changing some of the launch options. Which didn’t do anything)

I don’t know what to do any more. Any help would be appreciated.

Edit: Computer memory is fine.

Reduce your graphics quality, such as model and texture quality. Or ask for the server to optimize/remove some of its content.

I’ll try that later. Will respond if it worked or it didn’t.

Didn’t work. Gave me the same error. I also verified the integrity of the game cache. Everything seems fine.

Mess about/test changing your graphics settings (down)

I did. Didn’t seem to change anything. Also edited my heap size, still not working.

I’m not seeming to get the error anymore. Still exits though.

I’ll go in more detail:

I joined this server a week ago. It worked fine during that week until they changed maps (which I don’t think would really be the problem.) they didn’t change anything else. I started getting the error after this. I have 4G of ram but It worked fine on my other steam account for over 2 years.

Do you get the issue on a server, map, single player, or multiplayer?