"Lua Panic! Something Went Horribily Wrong "Not Enough Memory"

Not Enough Memory…/ Failed To Lock Vertex Buffer…

To start of I love Garry’s Mod. But of course it has some bugs that make the game, well kind of stupid, no offense. I’ve had this happening to me on one server though but that server is kind of, my favorite, and I kind of spent some money on it. So if you can help me that would be amazing! Thank you for taking your time to read this, now I will list the things I have tried to do to fix this/these problems.

1.] Reset my computer, in any way possible. (USB, And using the settings.)
2.] Type in “-dxlevel 70” up to “dxlevel 98” in the launch options.
3.] Delete every addon and try and join the server.
4.] Download every addon and join the server
5.] And try join with it windowed.
6.] Drivers are up to date.
7.] Tried deleting the Gmod folder and reinstalling.
8.] Tried deleting local content and reinstalling.

If you can help in any way that would be amazing thank you!
In-all Total Gameplay time, 1,644hrs.

Are you using a laptop? If so, make sure you’re choosing to launch Steam with the dedicated graphics processor if you’ve got one.

No, i’m not using a laptop.

Off topic I am using a intel hd laptop and it can run garrys mod fine… Its hd 5500…

@op I have no idea, What does it say exactly??? oh and pc specs???