Lua Panic! Something went horribly wrong! not enough Memory

Hi!

My friend has recently bought a PC and has wanted to play some GMOD DarkRP. He’s tried to join a few other servers, and when the game has finished the loading screen it still comes up with the same “LUA PANIC! Something went horribly wrong!” error resulting in his game shutting down.
We’ve tried a handful of different things that have been suggested on forums. I list a few here:

  • Reinstalling the game
  • Installing the addons individually instead of letting the server force download them for you.
  • Forcing Windows 7 compatibility mode
  • Running as Administrator
  • Using these launch options “-dxlevel 98” “-dxlevel 90” “-autoconfig” (separately)
  • Removing all addons installed

And a few others things.
I’m not too sure why its doing this sort of error. His specs well exceed the ‘recommended’ with him having 16 gigs of ram and 4 gigs of vram on his 1050ti and he can play single player fine!

Any help would be highly appreciated.

I’ll insert an image of what it looks like. Thanks.

That isn’t enough VRAM for GMOD to run. I guess. To fix this problem watch this video.

Gmod is only capable of using 4GB of ram. Increasing the size of the page file won’t help.

Usually this error happens because you have too many addons installed, or you have a faulty script that is allocating memory endlessly. You have already mentioned that you tried without any addons, but I suspect that you only tried it without any workshop addons. Filesystem addons and other Lua scripts in your gmod folder could be the culprit. Remove these scripts if you know how to. Delete the whole gmod folder and re-download it if you don’t.

Also, try joining different servers. You automatically download and use all addons that the server requires you to use, so this will contribute to the problem.

Jcw, when my friend reinstalled the game he did delete it all entirely. I still don’t know why it does it for him :confused: I can join the servers he can’t. I may have a much better pc etc… but he should still be able to join. Any other things?

Lower your graphics settings (especially models and textures) to free up ram. There’s some servers I can’t join unless I’m on minimum settings.

Yeah :confused: he tried that already… Still unsure to why it’s doing it. I feel like its something that only a patch can fix. Not too sure though. Please keep commenting your potential fixes!

He can play Singleplayer, right? And is it only for DarkRP?

Yeah, he can play singleplayer fine. We’ve managed to find a few servers he can join, but 99% he can’t.
He’s tried TTT and that works. So it must be DarkRP. (I think)