Lua panic... yep i got it..

Well about a week ago, i got a new Computer (16GB RAM | Total Disk Space 2.8TB | GeForce GTX 1060 6GB …) and tried to join on a server wich i played on.
And I get this error after about 2-6 mins playing “LUA PANIC, not enough memory.” so i looked into le Task Manager… it used 3 GB RAM. Well, as only 1.5GB was used by OS it had enough, in theory.
I just came to the end where i have no idea how to fix it anymore…
Ive already tried everything i could find on le internet. Including heapsize, removing addons, reinstalling (about 4times), verfiy game data … etc…

I thank you already for any great ideas how to fix it.

EDIT:
Oh yeah and its Windows 10.

[editline]20th February 2017[/editline]

Tried GMOD_Factory_Reset.bat -> no change
Tried -dex95 -> Now crashes after 4-6mins WITHOUT any message.

It’s -dxlevel 95, not dex. Also, dedicate more memory to the heap with -heapsize <kilobytes>

Tried heapsize already no change. Gonna check out dxlevel.

[editline]20th February 2017[/editline]

Nope still the same lua panic…

[editline]20th February 2017[/editline]

tried aswell again -heapsize 8589934592 no change

Have you tested your ram, probably by opening at least one Chrome tab?

(No, but really might want to test it, wouldn’t hurt.)

Do you have a crash dump in the Garry’s Mod folder? It could show more information about why it’s crashing such as an addon suddenly going berserk.