Lua scripts do not run on Linux Mint

Doing **lua_openscript **will only open the default scripts in the lua folder, but it can’t find mine.

**File not found < nowhere > **Is the error.

First of, have you checked if the file exists on the server and its being AddCSLuaFile’d or on the client, and the route to it is correct?
Also, if you want to open scripts on the client, you should use lua_openscript_cl

I’m aware of this. And no, AddCSLuaFile does not work.

Lua scripts open fine on Linux Mint, you’re doing something wrong somewhere.

Yea, they do open. It just can’t find MY scripts ( for example, opening a random menu script works )

So, how is the file structure of your scripts and how are you trying to execute them?

The folder had addon structure, but I switched it to just files in a folder to see if that worked. It did not. I’m trying to run then with lua_openscript

To help you we need to know where you’ve got the files (serverside, clientside) and the file structure, like:
lua/autorun/something.lua
and else

I have files on both ends, but they’re all in one folder. And autorun would be for addon structure, right? I removed that.

The scripts I’m trying to access are in “lua/pLog”

Sorry if this isn’t what you wanted, I’m trying to understand.

Mate.
Linux = Lowercase folders/files

And autorun is not for addons, its just as it name indicates
“auto run”

[editline]1st September 2017[/editline]

So, basically try renaming pLog to plog

I did NOT know that xD. I’m trying to learn linux, so I never knew. Yes, that worked, thank you!

Marked as solved.