Mac OS X - Engine Error - Steam Error: No SteamUser

Mac user here. I’ve verified, deleted local content, completely reinstalled from scratch… But all I get when launching Garrys Mod is this error:

“Engine Error”

“Steam Error: No SteamUser.”

and the game then crashes.

Happens to me too. Can someone help me?

Confirmed. My Steam then decided to go on a crash loop on startup after this.

Mine is doing this too and I really want to play; Damn you Garry.

Why every time?

I think it’s Garry’s way of saying he doesn’t like Mac’s.

It’s this and Valve in general. Anything on Steam (including Steam itself) just does not like functioning as well as it does on PCs. Garry’s Mod is glitchy as hell on Mac either way. But it’s still the game I love most <3

Kleiner I was thinking the same thing. But I still love the game. Which is why I can’t give it up. FIX IT GARRY.

Tried everything, reinstalled, etc. It’s just not working, I assume we have to wait for Garry on this one.

Same issue here, i’ve tried just about everything, reinstalled, rebooted, updated steam, no change.

I just put out an update - any change?

Just tested on my macbook - all working now here

Garry,

Looks like that update fixed it!

thank you

Woop!