Mac Source games love crashing

Hey I have a mac(hackintosh) and it works perfectly with every game but source games
Including Garry’s mod.
I launch any source game and It starts running perfectly but after you load a map after 2 minutes it crashes and gives me the unexpected error of death.
Any way I can fix this?

Not sure how to fix this other than un-hackintoshing (or just dual booting) your computer and using a Windows OS like every “gamer” should be doing.

I honestly just don’t like windows
Now can someone please just answer the question with dignity?

Just dual boot. I’m sorry but no one is going to help you when you’re using an unsupported or hacked OS.

I’m sure there’s other source engine hackintoshes out there

You can start off with your specs

I think first thing is to actually see what is his problem. I do not have this problem apart from the GMod-Awesomium crash bug. There is one crash bug in CS:GO but that isn’t every 2 minutes. Maybe every hour or two and usually with the Operation: Payback pack.

Specs as Killervalon said would be a good start. OS details included (eg. version number).

Os:osx 10.8.3 official combo update
Gpu: gtx 560 nvidia
Ram:8gb
Motherboard:asus p8z68
So I trust its not a hardware issue…I shall post in the bugs area because there seems to be more than one sufferer of this cause

Just install Linux, It’s going to work better than a hackintosh is. (Garry’s mod is currently in beta for Linux, it should be available within the next few days).

mac is gey n lineux is 4 penguin fuks #windows #billgates #lol

If your going for something more user friendly and don’t want to have a huge learn curve, then go with Ubuntu (or even Mint).

Oh I missed the hackintosh bit. That can cause problems.

Naah I had alot of issues with Ubuntu including freezing up in games, a bit clutery at times, lower fps, liked forgetting source engine options and also the graphics had trouble when bumping it up to a nice level that works perfectly on any other os

Stop disproving what everyone’s telling you just to hide the facts.

Have you tried the obvious?

  • Restart computer, and steam.
  • Uninstall/Reinstall addons.
  • Validate game.
  • Defrag.

If none of this works, that your more-than-likely-crappy OS can’t handle GMod.
Run windows or Linux.

It’s already been found its a valve issue not an os issue