Mac users problem in experimental

Hi Guys,

First time poster, long time reader here.
I’ve been looking at the forums and reading these threads for quite some months now, but I haven’t come across my particular situation.

First of all: my apologies if my english is dodgy, it’s not my first language.

So a couple of weeks ago I tried to play the experimental branch, updated it via steam and tried to open it. It opened fine the 1st time, then the screen froze. I actually had to hard restart my macbookpro because nothing was doing anything. I restarted and restarted steam too, tried to reload rust and i get the error message “The application “rust.app” can’t be opened.” -10810.

Restart again.

Tried it again; then got the message: can’t open rust because it is already open (which it isn’t). So restart steam, force quit, look at all my running processes and open steam again. Try to play rust again, same error message can’t open rust because it is already open.

Then i thought, oh well, it’s the experimental branch, i’ll just stick to the good old normal alpha. But when switching back and trying to open Rust again, still the same error message: can’t open rust…blablabla.

Which is strange because i’ve shut down the computer a couple of times, restarted steam a couple of times.

The way i eventually got this fixed was by uninstalling Rust AND Steam, reinstalling everything, restarting the system and not go to the experimental branch.

Today i wanted to try to have a look at the experimental branch again, so i updated it through steam. And this time it doesn’t even load but immediately says: "The application “rust.app” can’t be opened. -10810

I’m wondering if any other mac users are experiencing similar problems? And if so; have you fixed it and have you been able to play the experimental branch (on a mac)?

I really love this game and the concepts you guys are working on, but I would hate to lose out on the experimental/eventually only version of rust.

A bit more information on my system:

I have a Late 2012 Macbook Pro 15"
2.2Ghz Intel Core i7
8Gb 1333 MHz DDR3
and running OSX 10.9.2

Any help would be greatly appreciated (except the “don’t buy a mac, buy a pc”-kind, i know pc’s are “better” for gaming)

Thank you for reading!
MrvanH

I had the exact same problem as you.

Experimental Branch
Here is what i did to fix it:

  1. Go on Steam
  2. Delete Rust’s local contents
  3. Reinstall Rust (make sure you make a Rust shortcut for your desktop)
  4. Install the Experimental Branch
  5. Open Rust with the shortcut you made on your desktop!
  6. Welcome to the Experimental Branch :slight_smile:

Some people don’t have to do steps 1-4 and can skip to step 5. I advise you to skip to step 5 before you do them all.

By the way, you have to completely restart your computer if you get that error. Just restarting Steam won’t help!

Let me know if it worked out for you.

Good luck!