MacBook on Garry's Mod

I’m running Garry’s Mod on a MacBook Pro 2010 under Windows 7 64 bit, and from an external hard-drive which I have all my Steam games on; I directly boot into Windows 7 64-bit…boot camp has all the drivers from Apple for Windows; the hard-drive runs through my FireWire port. I cannot start the game at all. No error is given. All of my source-engined games do this. Any ideas? It seems like the game freezes up on startup. It may successfully launch sometimes, like maybe 3% of the time. But even if it does launch, it usually freezes before I can load into a game. If I can get myself into a game it keeps running alright. When it does not launch however, hl2.exe just runs in the background. If you terminate the process through CTRL-ALT-DELETE prompts, it still messes up other Steam source games from running until reboot or hard-drive dismount. I don’t think the hard-drive is causing these issues. Launch options do not work. I tried every Direct X version imaginable. All game cache files verify when I check for integrity through Steam. I even tried re-installing the game. No good.

I’ve seen several threads that had a similar problem, in the end the problem was the external hard drive.

I tried a local install, still same problem. Any ideas?