Major FPS Lag

Hey. I’m getting on average around 25 FPS. Here’s my main computer specs before you ask:

CPU: AMD Six-core 3.3 GHz
GPU: NVIDIA GeForce GTX 550 Ti
RAM: 8GB 1333 DDR3

My GPU drivers are up to date as well. So, as you can tell, I should not have any issues running GMod on high or low settings. I’ve tried verifying cache and defragmenting, I’ve tried setting GMod’s launch options with -dxlevel 80, and finally, I’ve tried lowering the graphics to their lowest settings. If you guys have any suggestions, I would appreciate them. Thanks.

How long has this been going on for?

Maybe two weeks.

Obviously something nasty is running in the background. Open up task manager and kill some programs you don’t need, if that doesn’t solve it, delete everything G-Mod related, and start over again and do a fresh install.

I’ll try that. Thanks.

Edit: That didn’t seem to help very much. I still get around 30 FPS.

I should probably mention that I only seem to get FPS issues when looking at far away areas. I don’t know if that will help, though.

what map

Pretty much every map. I think I may have figured out the problem, however. My computer doesn’t have sufficient cooling… Nonetheless, I ordered two fans from newegg. Hopefully when I’m done installing them that will fix it.

Shit, I’m still getting FPS issues even after installing my two new fans. Other more graphic intensive games seem to have good FPS… just not GMod. So, I guess I still need help.

Does it seem to actually lag or is your FPS just not rising above 30?

Just a half-assed thought, but nvidia drivers are prone to conflicts with he source engine. I have a radeon HD 6450, it’s 50$, and I get around 125 fps on gm_construct. Obviously there is something locking the framerate below 30, the best thing to do is probably turn off vsync in-game AND on the nvidia driver manager, see if that works or set the target framerate to unlimited.

I think you should also know that there are very few games that support 6 cores- if you have multicore-proccessing enabled you might be dealing with looping conflicts which also might be causing a mass FPS drop. I’ve been through this before, even with my integrated Intel HD 2000 I still rose above 50 on gm_construct, so your hardware’s quality is not the issue.

Sorry what? Prone to conflicts? Are you kidding me?

Had Nvidia cards most of my PC life, never had conflicts, google shows no known issues of conflicts so I don’t know where your getting your info from. Try turning your setting all to max and get 125fps on construct on that card. FYI source does not support much multi-processing, in-fact very very few games actually support multi-threading.

@OP:
Go to nvidia control panel make sure drives are upto date correct version such as 32bit or 64bit, reset the profile to default. Undo and overclocking or underclocking on both CPU and GPU.

2 Weeks ago can you remember installing anything? Doing anything specific?

I used to have a nvidia card( Always had anisotropic filtering and transperency issues), constantly I had a lot of small, ambient issues but by then I’m sure they have changed by then. I think you are right that they aren’t ‘prone’ the conflicts, I was just making a point-

But my radeon card isn’t running by itself, though, I’ve tweaked it:

  1. Switches based on the task with i7 2000 graphics
  2. Partitioned Hard Drive
  3. Fan constantly running at 100%
  4. Optimized OpenGL (Makes the big difference)

I run Gmod on anisotropic x8,vsync off, post-processing bloom,1600x900, and all other settings high. If I ever have FPS issues, I just crank down the resolution and everything is fine. But without the tweaks, I would have to run on much lower settings.

Have you tried resetting your gmod folder(delete garrysmod/garrysmod)? I am having this problem too, after reformatting my computer yesterday. I went through each add-on one by one, and when I couldn’t find the source of the lag, I deleted the folder and then turned off custom file downloads.

FPS was fine after that, so I tested some more. I am pretty sure the problem is with ULX. My fps is perfectly fine until I enable custom file downloads and join a server with ULX installed. I downloaded it to my client to test it again, same thing, from 230 to 15 fps until I uninstalled it.

Yeah, I tried deleting garrysmod/garrysmod. That didn’t help much. On the other hand, it could be because of ULX seeing as how I frequently play on a server with it. Is there a way I can join ULX servers without having to download ULX?