Making garry's mod props: Milkshape 3d model imported from sketchup 8 showing bad texture.

Hi all. Anyone knows why this happens when i import models from google sketchup to milkshape?

this is what i did:

1- Made a model in sketchup
2- Using ASE exporter plugin, i exported the file.
3- Using Biturn i converted the *.ase file to *.ms3d (milkshape binary).
4- Opened the milkshape file and i got the model showing.
5- I already made a *.vtf texture using VTFEdit.
6- I assign the texture to the model and it shows like in the picture 1.
7- Later after compiling, in game, it’s showing the same problem even if i change the material with a stool.

If i make the model from scratch using only milkshape it shows correctly textured both in game and on milkshape, shown in picture 2.

Picture 1:

http://img262.imageshack.us/img262/8922/milkv.th.jpg

Uploaded with ImageShack.us

Picture 2:

http://img209.imageshack.us/img209/25/milk2.th.jpg

Uploaded with ImageShack.us

I cant believe nobody say’s something. Come on.

Have you tried the Models/Skins Section?

it’s ok if i make a 3rd thread with the same content on a different section? I already made 2 threads.

I never liked Milkshape for texturing, although its a great program to start making models with.

[editline]28th January 2011[/editline]

You should really make a easy model like that in Milkshape, not importing it

I’m not very familiar with milkshape, and google sketchup is a lot easier. My idea is to make spacebuild like models, note the model on picture 1, its a straight tunnel, its fine on game and its great with easyprecision but i have this issue with the texture. Cant we just change the texture dimension on milkshape? the texture is there in very small tiles, if i zoom in close i see the texture perfectly repeating hundreds of times.

sorry for my english. :wink:

Solved !!!
Going to window and then texture coordinate editor, i sucessfuly align the texture well.

thanks for any help.