Making Models 'prop_static' compatible.


I will keep it brief: When placing ‘prop_static’ props in Hammer while using a model which isn’t compatible with being used this way, it won’t show in the map. I was wondering if there was a way I could edit an existing model to support being used in this way? I don’t want to change it to a prop_dynamic/physics or anything, for this is more expensive. I just want models to be compatible to be used with the more efficient ‘prop_static’ entity.

Thank you.

I think you need to add the cmd $staticprop to the .QC so it can be static as well

You can also use this as well

Perfect, exactly what I needed, thank you very much.

EDIT: Actually, it seems that it still has the requirement that the models have the ‘STATIC’ flag, which still leaves me troubled for most of the models I want to use.

[editline]22nd October 2017[/editline]

Would this only be possible if I’m compiling the model myself?

did you add -allowdynamicpropsasstatic to the vbsp compile options?

Yeah, but when reading the README it says it won’t apply to all non-static compatible models, rather, only ones which have ‘STATIC’ ticked in the Hammer model viewer, but can’t be used as Static despite this fact. (there are a lot of these annoying models so this edited vbsp is helpful as it is.) but it looks like it won’t work with all models, sadly.

You can decompile models using crowbar, add $staticprop to the .qc file (it’s just a text file) then recompile with crowbar.

Hm, okay, i’ll try this - thank you.

Are there any drawbacks, and is there a way to do that in bulk?

crowbar can decompile and recompile models in bulk. use the “folder” or “folder and subfolder” options instead of “file”

My usual workaround for this is using prop_dynamic_override. It probably has some downsides I’ve yet to discover, but it allows me to use anything as a prop . I do this since many props that are flagged as static in the model viewer disappear when compiling the map because VBSP complains that they’re not static. No idea why the model viewer claims they’re static, but this “fix” works.

One obvious downside is that you are using expensive dynamic props with buggy dynamic shadows even if there is no reason for them to be dynamic props.

You also don’t get per-vertex lighting.