making smooth walls - no lines between props

is there any way to build walls that do not show gaps? e.g. would like the building in the background to have no lines on it: see screenshot here http://steamcommunity.com/sharedfiles/filedetails/?id=491671221

p.s. i can up the graphics options as much as i like but the lines are still there…

Because you left space in between your props when you stacked them/placed them.

Unless you mean the black lines, in which case that’s simply the material you’re using.

the problem is that we have experienced lots of lag due to constraints, so we dont want to use no-collide everywhere, or is there no other option? and if not using no-collide and the props are “inside” each other then that’s going to cause even more lag according to my limited understanding? (we use stacker improved with 0 so that should be as close as you can get without collisions or illegal placements)

Then no, there is no other way. You can’t remove space without something filling it. Set the stacker tool’s Forward/Backward offset to -0.5