Map covered in darkness

Hi guys, I joined this forum just to fix something.

I’ve lately joined an rp server due to a friend’s request, and the map isn’t working out very well.

See this map : http://www.garrysmod.org/downloads/?a=view&id=118081

The images, that’s how it should be, but when I do it, the whole map is covered in darkness. I can see the silhouettes of the buildings, but the light isn’t there, it’s just dark and I can’t see well.

I was using -dxlevel 80 while I played on it, and I also used -dxlevel 70 when 80 didn’t work. I haven’t yet tried the original, as I doubt it will work.

Does anyone have a solution to this?

I want to hurry and start playing properly, but pitch dark maps aren’t helping.

Actually, -dxlevel 90 or 91 might just fix it, since some shaders/resources/etc. are made only in DX9 due sometimes in part to laziness on the creator’s behalf.

I’ve tried running the map on single player, and now it runs fine with all the lights working great.

It only bugs up on the server.

Maybe it’s due to the OpenAura thing the server uses, or maybe the mod?

Or maybe it’s because of all the things that was added to the map in the server.

I still haven’t found the solution, and why it’s causing this.