Map isn't updating with expert compile

I posted this in the help section but didn’t get too many responses so I’m posting it here.

When I compile the map in Normal mode it compiles and updates fine. When I compile in expert mode it does not update UNLESS I compile in normal first and then expert. The weird thing is that when I compile ONLY in expert mode, the file says it was modified at the correct time but none of my changes are there.

The only thing I have in my expert compile is -staticproplighting and I know it is in the correct spot as it works when I do the normal+expert compile.
Any help would be greatly appreciated as it is a pain in the ass to compile twice.

File -> Save as -> '…map_name


01

Now push F9 and try compiling in expert mode, remember to start map_name01 instead of map_name

Still didn’t work. I dont understand what that would do anyways.

If it’s something with project or something then making new project by saving your work to another file should solve it, but when I think longer about it, it seems like your map won’t compile at all

Where did you add the -staticproplighting? Maybe you placed it the wrong place and thus crashing the compile?

Try compiling in expert mode without -staticproplighting. If it works, then it’s your problem.

@Netheous - I already tried saving it to another file. And it does compile because when I make changes and do a normal compile and then an expert compile the changes show up in game.

@Zyx - I put it in the light_exe. I listed the parameters below.
$light_exe
-staticproplighting -game $gamedir $path$file

The reason why it makes the changes with the normal compile then expert, is most likely because it still fails at the expert compile, but as it worked with the normal it did update the map.
Have you tried expert without the -staticproplighting?

I removed staticproplighting and it still doesnt update. Is there something to reset the expert compile options? I tried reseting game config and uninstalling/installing sdk but that didnt do it. I’m thinking that I might’ve messed with something else by accident.

Here’s what I all have.

$bsp_exe
-game $gamedir $path$file

$vis_exe
-game $gamedir $path$file

$light_exe
-staticproplighting -game $gamedir $path$file

Copy File
$path$file.bsp $bspdir$file.bsp

$game_exe
-dev -console -allowdebug -game $gamedir +map $file

Post the compile log.

[editline]07:32PM[/editline]

Or maybe you just aren’t noticing the difference.

I’ve posted all the compile logs into the error checking tool on interlopers and I’ve scanned over them myself and have never seen any problems.
As for the changes. I usually make pretty large changes when I test to see if the expert compile is working, such as copying a pillar and putting it in the middle of the floor. I can also tell when -staticproplighting isn’t working, so I do know the expert compile is doing it’s job.

I worked on the map more last night and for some reason it worked every time when I did expert compile even though I didnt change anything. So it might have somehow worked itself out.