Map Lag

Well i finished my first map.

Everything works perfectly fine, all doors, lighting, my skybox, etc.

The problem is that the map is extremely laggy.

When your in the map you load The entire map, everything in the map. I tried adding hidden/skip portions and that didnt help at all.

What am i doing wrong?


Well thanks for help everyone, they pointed out a few problems.

Since i had multiple leaks, for me to find out where, i just make a dark box around the map and put bright lights everywhere. Then i went inside the box after compiling and saw where the light was coming through.

Thanks for help though.

is VIS set to Normal?

Yes its set to Normal.

Did you happen to drag a huge func_viscluster over the entire map?

Can you see every part of the map when you type in “mat_wireframe 1” to the in-game console? (without quotes)

No to the func_viscluster

And yes to Mat_wireframe

[editline]08:11AM[/editline]

I started to add areaportals to all doorways and windows. No difference yet since i have nothing inside.

Are you using many flickering\changing lights?

http://rvanhoorn.ruhosting.nl/optimization.php?chapter=intro

[editline]07:51AM[/editline]

Also take a pic of what your map looks like with mat_wireframe on.

snip snip snip.

By the way OP, give us some pictures to look at of your map, in hammer and ingame, and like firegod said with wireframe on.

Sorry i couldnt post picture of wireframe in-game. Once i enabled wireframe, it instantly crashed Gmod. I tried 3 times.

But heres the pics in hammer.

http://img412.imageshack.us/slideshow/webplayer.php?id=32133584.jpg

What the fuck why do you have a random hint brush going across the map like that?

I would try adding in fog with a far z clip plane.

It might have leaked.

Thats what ive been thinking, That there might be a leak. But if there is, i have no idea where. Any idea on how i can find it? And ill try the fog thing now.

Map> Load point file. If you see a red line, follow it to the hole. entities, props, brush entities, displacements, and water do not fill the hole.

It’s not “If you see a red line”. If it asks you to pick a point file, there is no leak. If it doesn’t, there is a leak and you need to find the red line.

It asked me, shows no red line.

[editline]02:47AM[/editline]

Well i double checked, and i purposely made a hole and used load point file, and did the same thing.

Its not showing me any red line, or anything at all.

Uh, you compiled first right?

post the compile log, VBSP isn’t writing a new bsp because of some other error (I’m betting he’s got something really close to the edge of the grid)

Fog didnt help, and no nothing close to edge, ill post it in a a second.

And how the hell else can i play the map if i didnt compile it?

[editline]04:36AM[/editline]

[editline]04:39AM[/editline]

And yes, you dont need to mention about the area portals or the props.

You have a leak in your map. Load Pointfile should load something… but make sure there isn’t any entities or brushes floating around in the void.

Too many light styles on face is a fatal error if I remember correctly, you should fix that and the other errors in there.