Map lags, no clue why

Hello there fellow Facepunch users, I have this really weird problem with my server. First of all I want to say, that the cpu isn’t close to being 100% used, nor is the ram or bandwith.

So, these are the problems:

  • In the map I can not drive any vehicles without lag, in the admin world (a big empty space, with 4 walls) it works.
  • When more players connect the server lags really hard, although the server’s resources are still not close to 100% usage.
  • This is a minor issue: when people join the server, it lags really hard for about 10-15 seconds (maybe it’s locally loading the map?)

What I think might be the cause:
I think the game loads the whole map, instead of everything visible, which might be the cause, although it is only a theory.


So what can I do to fix these problems? My last problem (the join lag) isn’t that bad, but the first 2 are really annoying…

What Map causes the lag ? how many addons does your server have ? whats the bandwidth to your server ? and whats your max player limit ??

It is this map: http://steamcommunity.com/sharedfiles/filedetails/?id=862361569
I have 95 Addons installed, my bandwith is definetly not a problem, as I have metioned before http://beta.speedtest.net/result/6091269714 and it is currently set on 16 slots, although it starts lagging when 3 or more people are on it. Since it’s in development, I haven’t had more than 5 players at a time on it yet.

There’s your problem.

I don’t see how that would be a problem, can you please explain this further? Also what if I merged them to 1 big collection?

There’s just too many addons for the server to handle.

I guarentee at least half of them are not optimized.

Is there any other solutionthan deleting them? Because as I said, the resources aren’t even close to being 100% used.

The amount of addons you have is not the issue… :rolleyes:

What I did when I had this issue is that I downloaded a FPSboost file which configures my Garry’s Mod everytime I execute it. Worked perfectly for me so try it yourself, if you want me to send it to you let me know…

Since when were we talking about client performance? and yes, having a shit load of addons will decrease your fps.

I have over 500 addons in use, as I said, it’s all about the FPSBoost config file, it will solve the issue. To Configure your Garry’s Mod will help you out a lot when it comes to joining servers and performance.

Thank you so much for your post! This is exactly what I needed, issue solved.