Map not compiling

Hello,My map is not compiling and I’ve been looking for days to fix this issue. Im compiling a custom rockford map just so you know. Can anyone help me? Here are the logs :

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod\bin\vbsp.exe”
** Parameters: -allowdynamicpropsasstatic -notjunc

Valve Software - vbsp.exe (Apr 29 2016)
allowdynamicpropsasstatic = true
notjunc = true
Command line: “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod\bin\vbsp.exe” “-allowdynamicpropsasstatic” “-notjunc”

usage : vbsp [options…] mapfile
example: vbsp -onlyents c:\hl2\hl2\maps est

Common options (use -v to see all options):

-v (or -verbose): Turn on verbose output (also shows more command
line options).

-onlyents : This option causes vbsp only import the entities from the .vmf
file. -onlyents won’t reimport brush models.
-onlyprops : Only update the static props and detail props.
-glview : Writes .gl files in the current directory that can be viewed
with glview.exe. If you use -tmpout, it will write the files
into the mp folder.
-nodetail : Get rid of all detail geometry. The geometry left over is
what affects visibility.
-nowater : Get rid of water brushes.
-low : Run as an idle-priority process.

-vproject <directory> : Override the VPROJECT environment variable.
-game <directory> : Same as -vproject.

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod\bin\vvis.exe”
** Parameters: -game “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod/garrysmod” “c:\users\assil\desktop\steam\steamapps\common\gar rysmod\bin\mapc”

Valve Software - vvis.exe (Dec 9 2014)
8 threads
reading c:\users\assil\desktop\steam\steamapps\common\garr ysmod\bin\mapc.bsp
Error opening c:\users\assil\desktop\steam\steamapps\common\garr ysmod\bin\mapc.bsp

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod\bin\vrad.exe”
** Parameters: -both -final -game “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod/garrysmod” “c:\users\assil\desktop\steam\steamapps\common\gar rysmod\bin\mapc”

Valve Software - vrad.exe SSE (Dec 9 2014)

Valve Radiosity Simulator
8 threads
[Reading texlights from ‘lights.rad’]
[45 texlights parsed from ‘lights.rad’]

Loading c:\users\assil\desktop\steam\steamapps\common\garr ysmod\bin\mapc.bsp
Error opening c:\users\assil\desktop\steam\steamapps\common\garr ysmod\bin\mapc.bsp

** Executing…
** Command: Copy File
** Parameters: “c:\users\assil\desktop\steam\steamapps\common\gar rysmod\bin\mapc.bsp” “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod\bin\mapc.bsp”

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod\hl2.exe”
** Parameters: -dev -console -allowdebug -game “C:\Users\Assil\Desktop\Steam\steamapps\common\Gar rysMod/garrysmod” +map “mapc”

Thank-you.

The allowdynamic commandline option you’re using only works with the custom VBSP provided here.
http://forum.facepunch.com/showthread.php?t=1488605

It will not work with stock valve VBSP and will throw the error you’re providing.

Oh ok, so basically, I need to modify my vbps.exe right?

Or remove the commadnline option you specified, yes.

Hey, so how do I modify this to make it work again?

$bspdirallowdynamicp$p$pathat$bspdirh$file$file.$ext$exedir$exedirropsasstatic -notjunc -game $gamedir $path$file

[editline]8th February 2017[/editline]

Ok I fixed it, thanks for your help, but I still get this :

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod\bin\vbsp.exe”
** Parameters: -notjunc -game “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod/garrysmod” “c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2”

Valve Software - vbsp.exe (Apr 29 2016)
notjunc = true
8 threads
materialPath: C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod\garrysmod\materials
Loading c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2.vmf
ConVarRef mat_reduceparticles doesn’t point to an existing ConVar
Can’t find surfaceprop marble for material AGENCY/FLOOR/MARBLE01A, using default
Can’t find surfaceprop marble for material AGENCY/WALL/MARBLE01, using default
Can’t find surfaceprop marble for material AGENCY/FLOOR/MARBLE02, using default
“materials//3dblur.vtf”: cached version doesn’t exist
Can’t find surfaceprop sheetrock for material PLASTER/PLASTER_INT_18, using default
Error: displacement found on a(n) func_detail entity - not supported (entity 3171, brush 35)

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod\bin\vvis.exe”
** Parameters: -fast -game “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod/garrysmod” “c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2”

Valve Software - vvis.exe (Dec 9 2014)
fastvis = true
8 threads
reading c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2.bsp
Error opening c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2.bsp

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod\bin\vrad.exe”
** Parameters: -bounce 2 -noextra -game “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod/garrysmod” “c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2”

Valve Software - vrad.exe SSE (Dec 9 2014)

  Valve Radiosity Simulator     

8 threads
[Reading texlights from ‘lights.rad’]
[45 texlights parsed from ‘lights.rad’]

Loading c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2.bsp
Error opening c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2.bsp

** Executing…
** Command: Copy File
** Parameters: “c:\users\assil\desktop\steam\steamapps\common\garrysmod\bin\mapc2test2.bsp” “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod\bin\mapc2test2.bsp”

** Executing…
** Command: “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod\hl2.exe”
** Parameters: -allowdebug -game “C:\Users\Assil\Desktop\Steam\steamapps\common\GarrysMod/garrysmod” +map “mapc2test2”

Go back and select all displacements on your map and click “ToWorld.” You cannot have displacements as brush entities.

Sorry, I’m kinda noob to hammer, but how do I do that?

Make sure you have “Groups” or “Objects” selected in the Selection tab or changing the brushes into world brushes won’t do anything.

http://i.imgur.com/RmofKTf.png[/T]

[editline]9th February 2017[/editline]

[T]http://i.imgur.com/zdcOzvz.png

Select all your displacements through Visgroups tab, make sure you have Groups or Objects ticked and then click on ToWorld

EDIT:

Good point

He actually need to disable everything but func_detail with visgroup.
And then find the func_detail looking like a displacement

Selecting all the visgroup Displacement and making them all to world won’t fix as the displacement causing error is not anymore under the displacement visgroup.

Let me try

[editline]9th February 2017[/editline]

THANKS SO MUCH GUYS!! It’s now working again properly!!

I still have this problem tho : http://images.akamai.steamusercontent.com/ugc/84842993827058398/BE4473E26256FB40AE4E6E7F72A767AA86969BD2/

I don’t really know how to make grass looks good.

EDIT : I FOUND THE FIX, THANKS SO MUCH THO!