Map not compiling

I’m having trouble getting this map to compile on Hammer.
I checked for errors on the map and it says no errors. When I try to compile it doesn’t make the .bsp for it. I thought mabye there aren’t any errors and it’s just taking a long time because its a big map. After leaving it on the compile screen all night I came back to find it still wasn’t there. I’m not sure why this map won’t work.

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\ultimathedgehog\sourcesdk\bin\orangebox\bin\vbsp.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod” “C:\Program Files (x86)\Steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.vmf”

Valve Software - vbsp.exe (Jul 7 2010)
4 threads
materialPath: c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod\materials
Loading C:\Program Files (x86)\Steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.vmf
ConVarRef mat_reduceparticles doesn’t point to an existing ConVar
Brush 12897: MAX_MAP_BRUSHSIDES
Side 0
Texture: DEV/DEV_MEASUREWALL01D

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\ultimathedgehog\sourcesdk\bin\orangebox\bin\vvis.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod” “C:\Program Files (x86)\Steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved”

Valve Software - vvis.exe (Jul 7 2010)
4 threads
reading c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.bsp
Error opening c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.bsp

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\ultimathedgehog\sourcesdk\bin\orangebox\bin\vrad.exe”
** Parameters: -both -game “c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod” “C:\Program Files (x86)\Steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved”

Valve Software - vrad.exe SSE (Jul 7 2010)

  Valve Radiosity Simulator     

4 threads
Could not find lights.rad in lights.rad.
Trying VRAD BIN directory instead…
Warning: Couldn’t open texlight file c:\program files (x86)\steam\steamapps\ultimathedgehog\sourcesdk\bin\orangebox\bin\lights.rad.
Loading c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.bsp
Error opening c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.bsp

** Executing…
** Command: Copy File
** Parameters: “C:\Program Files (x86)\Steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.bsp” “c:\program files (x86)\steam\steamapps\ultimathedgehog\garrysmod\garrysmod\maps\rp_c18_v1_moved.bsp”

P.S. this map is an edit of the Role-Playing map City 18. I was adding to it for my server.

You hit the brush limit
Brush 12897: MAX_MAP_BRUSHSIDES

Brush 12897: MAX_MAP_BRUSHSIDES

Optimize, remove some or many brushes.

Is there some way I can change the brush limit? If this map is at the brush limit I don’t understand how the original version worked or how maps that have more than this worked.

No. You decompiled your map and you will not get any support from us. If you want the .vmf ask the author.

OK where could I find the author? The reason I decompiled it is because I didn’t know how I could have edited for my rp server otherwise.

Editing maps without permission from the author is a very bad thing to do. If you decompiled a map when you did not even bother to find out who the author is, you deserve no help from us.

I’m not doing anything wrong. It’s not like I’m even trying to take credit for the map. I’m just trying to use it for my dedicated rp server. I didn’t know I needed the author’s permission to change anything about the map, it’s not like it’s something copyrighted or purchased it’s just a map out there in the gmod community to be used by anyone. If I have to get the author’s permission then I gladly will. You don’t have to act that way though.

Yes we do. It is copyrighted like everything else somebody does. If I make a map, and somebody decides to take it and mess with it, I can do/say something about it.

If you really want to edit the map, ask the author for the .vmf, if he doesn’t give it to you, then deal with it and get over it. We aren’t going to support people who decompile maps for stupid reasons.

I don’t think you read what you quoted from me. All I said was I didn’t know I had to get permission to add minor changes. I didn’t expect that but I will gladly ask the authors now, but you are acting like I’m doing something horrible even though I stopped trying to edit the map and I’m going ask the authors when they are online.
I wasn’t asking for ‘support’ on the map as you keep saying I was asking who the authors were and you think telling me is supporting crime. I found them now so it doesn’t matter.

You obviously don’t know how copyrights work.

you’re not getting into legal trouble for decompiling a community map but the community looks down upon it and will not help you, besides, if the map is ‘advanced’ it’ll be almost useless trying to recompile it

Advanced? What do you mean by that? Also does anyone know how the map existed when it was over the brush limit?

Note: I’m not even doing anything with city 18 right now before anyone else says you won’t support me. I’m just someone trying to learn how to make maps and was using city 18 until I had my own.

When you decompile the map, the decompiler guesses at brushes and faces, it doesn’t do it perfect. Thats why I said to get the .vmf from the author and not decompile it.

The best way to learn how to make maps is to make your own, not try to recompile decompiled work of other people’s.

As I said, I am making my own but am using City 18 on my server until it is finished.

P.S. It seems like every time you quote me, you did not read what was quoted as what you said is opposite of the quote.

Use it in it’s original form. Never decompile.

rp_c18_v1_moved.vmf

That doesn’t look much like your own map to me.

And you just did it again. That is city 18, which I am using until I’m finished making my own map. I wanted to make a small change to city 18 while I’m using it to suit my server.

Just to shed some light on this subject, the map is not copyrighted. You must register a copyright with your local government, which costs heaps of money, far more than a map is worth. I will eat my hat and my pants if anyone has literally copyrighted their map. It is certainly discouraged, but it is not illegal in any way. Note there is something coined a “poor man’s copyright” which costs little to nothing, but it is not necessarily upheld by the United States government. I cannot speak for its integrity elsewhere.