Map Off Scale

Hello Facepunch community! I have a question that begs for answering.

I’ve been working on my first map. After doing a decent amount of work, I noticed that my map was way out of scale. Like, the maximum amount of out of scale-ness. But I figured I could fix this any time I wanted to by just scaling up. Turns out, not so much.

I multiplied my scale by either 3 or 4 times. However, now all the edges are ever so slightly off by the same margin, lost in the fractions of the grid:

http://media.giantbomb.com/uploads/7/79000/1857554-grid.png

This obviously makes aligning edges of brushes impossible. Are there any precision tools I could use to get my map back on track and be absolutely sure that it’s aligned properly with the grid? Is there any way to get an even smaller grid size? Otherwise I suppose I’ll have to start all over, which would be a huge pain.

Well there is selecting the stuff and right clicking and selecting align to grid i believe but i don’t think that would work. Just don’t scale things if you want things to be the right size you should use the dev textures for the purpose like a wall is usually 128x128. If you still have your map up just undo the changes.

Select everything and go to tools>snap selected to grid individually

Yeah your best bet at this point would be to just start over.

If you’re having trouble with getting your maps to the appropriate size this can be a really helpful article; http://developer.valvesoftware.com/wiki/Dimensions

But like Stinky said, it’s generally a good idea to use 128 unit tall walls for general sized walls. Like office spaces, houses, etc.

If you need more visual aid you can just an info_player_start entity to get an idea of how big things will be around the player.

Tried this. It gets me maybe 20% of the way there, but I would have to manually realign everything… Might be a better option then starting from scratch though.

I was working off of an imported reference mesh, so I couldn’t really apply standardized measurement. Trouble was, while my reference IS to scale, somehow that got lost in the export procedure.

[editline]8th August 2011[/editline]

Oh hey! I… I think I fixed it.

I reverted back to before I scaled the map, scaled it again by 6x (using ctrl+M instead of my hackneyed calculations and manual scaling) and ran align to grid individually. It magically aligned without any gaps. Well, haven’t seen any so far.

That same corner:
http://media.giantbomb.com/uploads/7/79000/1857580-grid_fix.png

Thanks for the help guys.