Map on Linux Server issue

Hello,

I’ve a problem on my Linux server, when i want to change my map with “rp_headattackcity_v1” my server doesn’t want to start… With others map like “rp_downtown_v2”, “rp_townsend_v2” it work… I don’t know why this map doesn’t want to start with linux server because on windows server it work !

I’ve only this error : Segmentation fault $HL_CMD

Can someone help me please ?

add -debug to the server and post the log.



[Thread debugging using libthread_db enabled]
Using host libthread_db library "bin/libthread_db.so.1".
[New Thread 0xb74b8b40 (LWP 22472)]
[New Thread 0xb6cb7b40 (LWP 22473)]

Console initialized.
Couldn't load shader dll: game_shader_generic_garrysmod_srv.soConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
[New Thread 0xae41cb40 (LWP 22474)]
[New Thread 0xae31bb40 (LWP 22475)]
[New Thread 0xae21ab40 (LWP 22476)]
Setting breakpad minidump AppID = 4000
[New Thread 0xab118b40 (LWP 22477)]
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[New Thread 0xaa0a2b40 (LWP 22478)]
Logging into anonymous gameserver account.
Fetching Workshop Addons.. host_workshop_collection is unset
[New Thread 0xa9988b40 (LWP 22480)]
[Thread 0xaa0a2b40 (LWP 22478) exited]
[Thread 0xa9988b40 (LWP 22480) exited]
[New Thread 0xa9988b40 (LWP 22481)]
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Server logging enabled.
Server logging data to file logs/L1006126.log
L 10/06/2014 - 17:50:33: Log file started (file "logs/L1006126.log") (game "/data/dedigames/dedigame9/home/servers/server1671/games/gmod/garrysmod") (version "5725")
Server logging enabled.
L 10/06/2014 - 17:50:33: Log file closed
Server logging data to file logs/L1006127.log
L 10/06/2014 - 17:50:33: Log file started (file "logs/L1006127.log") (game "/data/dedigames/dedigame9/home/servers/server1671/games/gmod/garrysmod") (version "5725")
Server logging enabled.
L 10/06/2014 - 17:50:33: Log file closed
Server logging data to file logs/L1006128.log
L 10/06/2014 - 17:50:33: Log file started (file "logs/L1006128.log") (game "/data/dedigames/dedigame9/home/servers/server1671/games/gmod/garrysmod") (version "5725")
Network: IP 194.105.152.175, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
L 10/06/2014 - 17:50:33: server_cvar: "mp_flashlight" "1"
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
L 10/06/2014 - 17:50:33: Log file closed
Server logging data to file logs/L1006129.log
L 10/06/2014 - 17:50:33: Log file started (file "logs/L1006129.log") (game "/data/dedigames/dedigame9/home/servers/server1671/games/gmod/garrysmod") (version "5725")
L 10/06/2014 - 17:50:33: Loading map "rp_rockford_beta"
L 10/06/2014 - 17:50:33: server cvars start
L 10/06/2014 - 17:50:33: "sbox_persist" = ""
L 10/06/2014 - 17:50:33: "sbox_bonemanip_misc" = "0"
L 10/06/2014 - 17:50:33: "sbox_bonemanip_player" = "0"
L 10/06/2014 - 17:50:33: "sbox_bonemanip_npc" = "1"
L 10/06/2014 - 17:50:33: "sbox_weapons" = "1"
L 10/06/2014 - 17:50:33: "sbox_maxemitters" = "20"
L 10/06/2014 - 17:50:33: "sbox_maxbuttons" = "50"
L 10/06/2014 - 17:50:33: "sbox_maxhoverballs" = "50"
L 10/06/2014 - 17:50:33: "sbox_maxthrusters" = "50"
L 10/06/2014 - 17:50:33: "sbox_maxwheels" = "50"
L 10/06/2014 - 17:50:33: "sbox_maxlights" = "5"
L 10/06/2014 - 17:50:33: "sbox_maxlamps" = "3"
L 10/06/2014 - 17:50:33: "sbox_maxdynamite" = "10"
L 10/06/2014 - 17:50:33: "sbox_maxsents" = "100"
L 10/06/2014 - 17:50:33: "sbox_maxnpcs" = "10"
L 10/06/2014 - 17:50:33: "sbox_maxballoons" = "100"
L 10/06/2014 - 17:50:33: "sbox_maxeffects" = "200"
L 10/06/2014 - 17:50:33: "sbox_maxvehicles" = "4"
L 10/06/2014 - 17:50:33: "sbox_maxragdolls" = "10"
L 10/06/2014 - 17:50:33: "sbox_maxprops" = "200"
L 10/06/2014 - 17:50:33: "sbox_playershurtplayers" = "1"
L 10/06/2014 - 17:50:33: "sbox_godmode" = "1"
L 10/06/2014 - 17:50:33: "sbox_noclip" = "1"
L 10/06/2014 - 17:50:33: "physgun_limited" = "0"
L 10/06/2014 - 17:50:33: "mp_friendlyfire" = "0"
L 10/06/2014 - 17:50:33: "mp_fadetoblack" = "0"
L 10/06/2014 - 17:50:33: "sv_hl2mp_weapon_respawn_time" = "20"
L 10/06/2014 - 17:50:33: "sv_hl2mp_item_respawn_time" = "30"
L 10/06/2014 - 17:50:33: "sv_report_client_settings" = "0"
L 10/06/2014 - 17:50:33: "sv_gravity" = "600"
L 10/06/2014 - 17:50:33: "sv_stopspeed" = "10"
L 10/06/2014 - 17:50:33: "sv_noclipaccelerate" = "5"
L 10/06/2014 - 17:50:33: "sv_noclipspeed" = "5"
L 10/06/2014 - 17:50:33: "sv_specaccelerate" = "5"
L 10/06/2014 - 17:50:33: "sv_specspeed" = "3"
L 10/06/2014 - 17:50:33: "sv_specnoclip" = "1"
L 10/06/2014 - 17:50:33: "sv_maxspeed" = "10000"
L 10/06/2014 - 17:50:33: "sv_accelerate" = "10"
L 10/06/2014 - 17:50:33: "sv_airaccelerate" = "10"
L 10/06/2014 - 17:50:33: "sv_wateraccelerate" = "10"
L 10/06/2014 - 17:50:33: "sv_waterfriction" = "1"
L 10/06/2014 - 17:50:33: "sv_footsteps" = "1"
L 10/06/2014 - 17:50:33: "sv_rollspeed" = "200"
L 10/06/2014 - 17:50:33: "sv_rollangle" = "0"
L 10/06/2014 - 17:50:33: "sv_friction" = "8"
L 10/06/2014 - 17:50:33: "sv_bounce" = "0"
L 10/06/2014 - 17:50:33: "sv_stepsize" = "18"
L 10/06/2014 - 17:50:33: "r_VehicleViewDampen" = "0"
L 10/06/2014 - 17:50:33: "r_JeepViewDampenFreq" = "7.0"
L 10/06/2014 - 17:50:33: "r_JeepViewDampenDamp" = "1.0"
L 10/06/2014 - 17:50:33: "r_JeepViewZHeight" = "10.0"
L 10/06/2014 - 17:50:33: "r_AirboatViewDampenFreq" = "7.0"
L 10/06/2014 - 17:50:33: "r_AirboatViewDampenDamp" = "1.0"
L 10/06/2014 - 17:50:33: "r_AirboatViewZHeight" = "0.0"
L 10/06/2014 - 17:50:33: "mp_timelimit" = "0"
L 10/06/2014 - 17:50:33: "mp_fraglimit" = "0"
L 10/06/2014 - 17:50:33: "nextlevel" = ""
L 10/06/2014 - 17:50:33: "sv_alltalk" = "0"
L 10/06/2014 - 17:50:33: "sv_allowcslua" = "0"
L 10/06/2014 - 17:50:33: "ai_disabled" = "0"
L 10/06/2014 - 17:50:33: "ai_ignoreplayers" = "0"
L 10/06/2014 - 17:50:33: "mp_teamplay" = "0"
L 10/06/2014 - 17:50:33: "mp_falldamage" = "0"
L 10/06/2014 - 17:50:33: "mp_weaponstay" = "0"
L 10/06/2014 - 17:50:33: "mp_forcerespawn" = "1"
L 10/06/2014 - 17:50:33: "mp_footsteps" = "1"
L 10/06/2014 - 17:50:33: "mp_flashlight" = "1"
L 10/06/2014 - 17:50:33: "mp_autocrosshair" = "1"
L 10/06/2014 - 17:50:33: "decalfrequency" = "10"
L 10/06/2014 - 17:50:33: "mp_teamlist" = "hgrunt;scientist"
L 10/06/2014 - 17:50:33: "mp_allowNPCs" = "1"
L 10/06/2014 - 17:50:33: "sv_password" = ""
L 10/06/2014 - 17:50:33: "tv_relaypassword" = ""
L 10/06/2014 - 17:50:33: "tv_password" = ""
L 10/06/2014 - 17:50:33: "deathmatch" = "1"
L 10/06/2014 - 17:50:33: "coop" = "0"
L 10/06/2014 - 17:50:33: "sv_cheats" = "0"
L 10/06/2014 - 17:50:33: "sv_pausable" = "0"
L 10/06/2014 - 17:50:33: "sv_contact" = ""
L 10/06/2014 - 17:50:33: "sv_voiceenable" = "1"
L 10/06/2014 - 17:50:33: "tv_enable" = "0"
L 10/06/2014 - 17:50:33: "sv_steamgroup" = ""
L 10/06/2014 - 17:50:33: server cvars end
PREP OK
Warning in .VMT file ($envmaptint): no ']' or '}' found in vector key "$envmaptint".
Did you forget to surround the vector with "s?
Engine hunk overflow!
Engine hunk overflow!

L 10/06/2014 - 17:50:34: Engine error: Engine hunk overflow!

Engine hunk overflow!


Program received signal SIGTRAP, Trace/breakpoint trap.
0xffffe424 in __kernel_vsyscall ()


[editline]6th October 2014[/editline]

If you have the same problem add : “r_hunkalloclightmaps 0” in your autoexec ! It work for me thank you very much Tomelyr !!