Map problem: missing files

Cheers!
Well im new to the forum, though i already knew it ^^
I’m currently with a problem in gmod, and ive come here to see if anyone could give me an hand with it.

I haven’t played in a while, and decided to do it today, only to find that any map that i download for garry’s mod when installled in the proper directory, doesn’t appear in the game’s menu. And on the map folder it is an empty icon in the place of the file of the map in question, which if clicked, it makes appear a message saying that “windows can’t open this file”.
I’ve recently installed windows 7 but i don’t know if that’s the cause for this problem.

I was hopping you guys could shed some light on this matter, i really want to try out the new awesome maps recently made for gmod.

thanks :slight_smile:

The maps you download from garrysmod.org are in the .zip format. Right-click them then click “Extract to…” and place them on your desktop or something. If there’s only 1 file, called “whatever.BSP” then place it in:
C:/Program Files/Steam/steamapps/username/garrysmod/garrysmod/maps

I don’t know much about Vista, but see if the file extension is still “.bsp”. You may have accidentally deleted the file extension if you were changing the name or whatever. If you can’t seem to change the file extension just by typing “[map name].bsp”, go up to “Tools”, click on “Folder Options”. In this window, click on the “View” tab, and un-tick the “Hide extensions for known file types”. This will allow you to change file extensions. I hope this helps!

I’ve already done that :\ the problem is the bsp file is there but it appears as an empty file with nothing on it. there’s an error with the bsp file , but i dunno what is it.

[editline]11:48PM[/editline]

Well since i’m using windows 7 i dont know how to do that, anyway, i haven’t touched the file’s name, and the .bsp is in it though it is empty :\

You have tried loading it in game right?

Because I don’t think Gmod can tell which OS you’re on.

If by loading you mean installing yeah, ive put it in the game file, but it didn’t work.
and what do you mean by OS?

He means you’re supposed to load the map from inside Gmod, not by clicking the map file outside the game.

OS = Operating System
In your case that’s windows 7.

What do you mean by “empty icon”? You could take a screen shot of it and post it here so we can take a look.

You are probably missing the game that comes with the materials, so all you see is a pink and black checker pattern, and some giant ERRORs. The only way to solve this is to find the materials in a download or buy the game. Most of the time, materials are borrowed from Counter Strike: Source and the Half Life 2 games.

I’ve placed the map in the C:/Program Files/Steam/steamapps/username/garrysmod/garrysmod/maps directory, but it doesn’t appear on the game…

[editline]12:37PM[/editline]

That’s not the case, the map doesn’t even show in the game’s menu.

btw, how can i post a screenshot here?

did you put the file in the maps folder when it was still in it’s “zipped” form? you need to open it and put the actual map file in the “garrysmod\garrysmod\maps” folder

Yes i’ve open it… i wanted to post a screenshot put i dont know how. :\

I dont know any more possible solutions other than you may need a new graphics card. Oh, and are you looking in the right area of the maps list? if the beginning of the map is gm_ then it will be in the garrys mod section. If it is rp, zs, z, or any others, it is probably in the “other” folder

Yes i’ve already verified that as well, the map doesn’t appear in any section of the game.
I don’t think that the graphic card is the problem, since when i was using windows xp it was the same and it worked, so it may be a windows 7 problem, i dunno :\

I wanted to post a screenshot, how do i do that?

Hit the Print Screen key (usually labelled “Prt Sn” or something) on your keyboard, then open Paint and hit Ctrl+V. Save the image then go to an image hosting site like filesmelt.com and browse for and upload your image. Then choose the “Forums/BBCode” link and paste it in your post.

And the only reason the icon for the map file is empty is because it’s in .BSP format, a file format Windows doesn’t know what to do with. But that’s OK because it doesn’t need to, seeing as you load maps from in-game.

[editline]04:56PM[/editline]

But before you do that, load up Gmod, open the console and type in “map [mapname]” then hit enter, to see if it loads. [mapname] is the name of the map you’re trying to open, without the .BSP on the end.

http://filesmelt.com/dl/gmodmap1.png

http://filesmelt.com/dl/gmodmap21.png

Here, 2 screenshots that may help you out to figure what the problem is. I’ve tried the console suggestion but it didn’t work. :
Sorry about the language, it’s in portuguese. But i think it can be understood easily.

Click “Organizar” in explorer, then click “Folder & Search Options” (I don’t know the Portugese for that though)

Once in that, click the “Views” tab, then uncheck the box that says whatever the portugese is for “Hide file extensions for known file types”. Click Apply/OK, then go back to your maps folder and check the file. What might have happened for some stupid reason is the file got renamed as gm_sealab.bsp.bsp, then windows detected the .bsp file extension and hid only the one from the end, leaving you with gm_sealab.bsp

If that has happened, rename gm_sealab.bsp.bsp to simply gm_sealab.bsp, then try it in-game.

You mean internet explorer?
I didn’t find anything with the name “organizar” in it. :expressionless:
would you pm me with some screenshots of how to do it as an example? I know this maybe asking to much but i think it’s more easy that way.
Sorry about my noob-like behavior >.>