Mapping Questions Megathread V6

Thread image courtesy of Grenade Man

If you have any mapping-related problems, use this thread to ask them, rather than creating a whole new thread.
This is not the place for requests. If you want to request a map to be found/made, create a new thread.
Do not post screenshots in this thread unless they are related to an error or question.

Figured I’d make a new one asap before questions start flooding in, since I made the old one close :frowning:
nice thread title scrub, can a mod fix it?

Hey there!
so I’ve been working on my first Hammer map for my community, spending roughly 10 hours a day for a period of 1 month. I’ve recently completed the map and it ran flawlessly in single-player with fairly average optimization via hint brushes/farZ. Upon dropping my map on the server everything was fine, however, once my playerbase hit roughly 35-40, many players had an abrupt drop of FPS all the way down to 0 - followed by the freezing and crashing of their Garry’s mod client. One user reported a prompt stating “can’t load lump XXXX bytes”.

I’ve been very frustrated in trying to fix this issue, I figured it was an optimization problem at first, and so, I’ve done things as i’ve stated above (nodrawing unseen brushes/proper skybox/skip-hints in proper locations) but the problem continues to haunt me. If anybody has any idea as to how I could go about tackling this issue, I would be extremely happy to learn.

The compile log shows no errors other than a quadruple log of “zero area child patch” which I was notified can generally be ignored. I could not determine the location of the problem.

EDIT: in the previous thread I was asked to attach a screenshot of the map. I will do so now:

Post images of the map layout. Are you using any “bad” optimization techniques? Like covering the entire map in a viscluster or using a skybox “box”??

Post images of the compiled map and also in game images with wireframe enabled. Also post the “map info” tab.

[editline]22nd August 2017[/editline]

Didnt see the edit

Sounds like a pretty bad error and not one I’d recommend ignoring, I suppose you can try using the cordon tool in smaller sections of the map until you find the area of brushes that cause this.

Could also (though probably not) be the gamemode the server is using?

Are those trees prop_statics? Are you using z clipping?

[editline]22nd August 2017[/editline]

My merge

doing a little google search if the actual error is


 Can’t load lump xxxx ,allocation of xxxxx bytes failed.” 

then it’s a client or server issue nothing map related

This sounds like a map problem to me. Or a gamemode problem.

No, I only used visclusters in the area between the top of my map and the skybox - ensuring that they do not come in touch with anything else.

Would you care to explain to me how to grab the “map info tab”? thank you!

asfar as an image of my map with wireframe enabled, I will do so first thing when I get home.

I will go ahead and try utilizing the cordon tool to pinpoint the source of that error, thank you for your suggestion. I was trying to avoid it the best I can as it seems like an incredibly tedious process, and I have no idea what to look after.
I crossed out the option of my gamemode being the issue, as I explained why in my response to taz0.

As I’ve stated in my thread, I am using zclipping for optimization, specifically, the value is at 5000. All the tress in the image are indeed static props.

While I did gather that much about the error (and yes, that is the correct error) I have been running my servers for 3-4 years, with a steady average of 40-50 users online at a time (100+ at peak times) and have never experienced such error by any user up until switching to my map. So i’d beg to argue differently.

[editline]22nd August 2017[/editline]

Well I mean, what else could it be haha.

Post the compile log, just to be sure. What power displacements are you using. What gamemode are you running.

Why do my Normal Map Shadows look like they are from 1999 :s:

https://steamuserimages-a.akamaihd.net/ugc/860605614882550687/CB7EAA5C8A3114B92CBA41559E8D02972F38B609/

Post normal map, post VTFedit texture import dialog, post image of opened .vtf

Nevermind. NOT compressing the vtf fixed it.

Diffrent Question tough. Can I make only one of my blend textures use envmaps? like in this picture:

http://static.asiawebdirect.com/m/phuket/portals/phuket-com/homepage/phuket-magazine/freedom-beach/pagePropertiesImage/freedom-beach.jpg

Something like the vmt below should work. The main trick here is to use normalmaps with different reflective properties. “$normalmapalphaenvmapmask” will give the texture stronger reflections the more opaque its normalmap is, and conversely almost transparent normal maps will have barely visible reflections.



WorldVertexTransition
{
$basetexture "nature/ground_mud01"
$basetexture2 "nature/ground_mud02"
$bumpmap "nature/ground_mud01_height-ssbump"
$bumpmap2 "concrete/pavement_height_low-ssbump"
$ssbump 1
$surfaceprop dirt
$surfaceprop2 mud

$blendmodulatetexture "nature/blendtexture01"

$envmap env_cubemap
$normalmapalphaenvmapmask 1

%tooltexture "nature/ground_mud01"
}


What’s the best way to make windows on an angle such as this?

Using only brushes or along with static prop windows?

Only with brushes

Personally, if I was just making out of brushes, I would use the clip tool to cut up the wall then use the vertex edit tool to shape the brushes. If I have time tonight I can see about making a short video clip to explain better

how do i make a winding staircase?

Couldnt find anything similar to my issue but for some reason I get this error when compiling now when using propper to convert brushes into props.

Yes I am using the 2013 propper. I have tried refreshing SDK content but that didnt fix it.

EDIT:Fixed it