maps wont load correctly

On some of the maps I have when I load them I get a lot of the error messages around the map and the other affects and buildings stretch into the sky. I really have no idea what is causing this if anybody could help that would be great.

Post the compile log.

Sorry kinda new to this so could you please explain what you mean by the compile log.

When a map is compiled, a window opens showing the status of the compile process. This information is also recorded to a .log file in the same directory as the .vmf. The newest compile is recorded at the end of the file.

OR he could just copy the log directly from the window in hammer?

Chances are he’s closed the compile window and hammer by now.

well. he can recompile it. He will get the compile log and if he dont get the error this time, its good.

Just throwing my thought out here,

Since he says “maps” maybe he means other maps, and not his maps.

And by error messages he means, lua errors, etc, missing textures, ERROR models.

Yeah, you got a point there. If its not just his own maps its proberly something seriously wrong

OP: try running gm_construct on vanilla install

This isn’t a map I created this is just a map a I am trying to run. These are the problems I am having with some maps I have downloaded.

[editline]12:57AM[/editline]

What is vanilla install?

Vanilla install is when you got no addons installed.

I tried that.

and the map still dosent work? Can you make a list of the maps you are getting odd effect on?

RP_EvoCity_v2d and RP_Downtown_V2

well, those maps are proberly not bugged in the release. Where did you downloaded them from and can you make a screenshot of what you mean

http://img382.imageshack.us/img382/5994/hl2gmod20090712060421.th.png

http://img16.imageshack.us/img16/6964/hl2gmod20090712060348.th.png

http://img200.imageshack.us/img200/4589/hl2gmod20090712060357.th.png

http://img16.imageshack.us/img16/3919/hl2gmod20090712060412.th.png

and all of the maps I have gotten have come from garrysmod.org

and you have installed the materials and models and so? couse all those purple/black chess means that you’re missing textures, and the errors mean that you miss models. What Source games do you have?

I have TF2, and all the half lives. My friend was running the map fine on his computer with the exact same files and set up and it worked fine. He never installed any materials at all he just got the map and it worked fine I got it and it looked all crazy.

and he dont have CSS? couse CSS props is often used in RP maps. If it comes Materials and models in the map zip, have you installed them correctly?