mat_specular 0 only on certain map

Hello, I have a map that a person ported over from CSGO (Don’t worry they made it for CS not stealing), reflections are messed up so it would be smart if we used mat_specular 0 in the server. My question is, is it possible to have mat_specular 0 only apply to one map? I would prefer not to put it in my server.cfg file as it would cause all maps to have the mat_spec. effect.

If you have questions about my question feel free to ask.

Fix the reflections.

You don’t understand, the map was a port from CS:GO and I’m using new nuke props. The new nuke props are using a custom envmap. In CSGO, the custom envmap doesn’t need a vmt, but in GMod, it does. I cant create an envmap VMT, just doesn’t work. Also making the props use env_cubemaps instead of the custom envmap doesn’t work. Trust me, I’ve been trying to find a fix for about 3 days now.

Thanks for your very valuable input on a problem I can’t fix.

Post the map name? Post the models/material paths in question?

I made the original map. Do you just want to add me then we can speak there?

If you “made the original map”, then post a link to the map file… PM it to me if you have to.

I sent a PM and added you on steam.

[editline]20th November 2016[/editline]

Need anything else?

Ok, so the problem is that GMod cannot load the VTF format those files use ( materials/enviroment maps ). Your options are:

  1. Hope that one day it will be fixed
  2. Ship “fixed” model .vmts that will alter the $env_map key or remove it inside your map
  3. Ship fixed enviroment maps/ .vtf files

I already tried doing this, replacing $env_map with “env_cubemap”. Still didn’t work. There is a env mask with a texture, but that has a vmt so it shouldn’t cause any errors, would it?

They arent broke, the problem is there is no VMTs. CS:GO does not need VMTs for env cubemaps, but GMod does.

Yeah, you tell me how shit works and what’s broke and not, I totally have no idea what I am talking about after replicating and fixing the problem.

Ignore the broken textures all around, you should’ve send me already compiled map.

Before:

http://i.imgur.com/6NuS6fz.png[/t]

env_cubemap: ( solution 2 )
[t]http://i.imgur.com/LjB4n71.png[/t]
( Note that it does not look like picture above, you can clearly see the corner seams of the cubemap texture, again, the cubemaps look like shit because you didn’t sent me the compiled map )

Fixed .vtf ( solution 3 )
[t]http://i.imgur.com/JSWaweB.png

Ok, what do you mean by fixed .vtf? I used vtfver to convert the files already

http://i.imgur.com/yrGYX16.png

Same thing on gm_construct

(nofix, env_cubemap, fixed .vtfs)

By fixed vtfs I mean reimported the texture in VTFEdit with BGRA8888 format

Reimporting all of the textures seems like alot of work, what is the env_cubemap fix? Replacing the $env_map with “env_cubemap”?

If you want a work around then just use something like



hook.Add( "InitPostEntity", "join_con_commands", function()
    if game.GetMap() == "mymap" then RunConsoleCommand( "mat_specular", "0" ) end
end )


on a clientside script

I’ll test it out and update this in a couple minutes

I managed to fix the problem, the textures should be loading fine in the next update ( you can test now in the Dev beta for Garry’s Mod )

Alright, thanks man.