Material problem on dedicated server...

Hello all,

So in singleplayer I have some materials I’d like to use on my server (localhost SRCDS). However these materials does not exists on this SRCDS server. I tried everything I could, but I can’t even find these materials in my GarrysMod directory in SteamApps.

For example, the material “materials/models/props_lab/warp_sheet” is missing from my server, but is in my singleplayer game.

The most strange is that all servers I can come in have those missing materials. I don’t unserstand why none of the SRCDS I can install using SteamCMD have those.

I even tried to mount games hl2, episodic, ep2, cstrike but none of them adds these missing materials. Even on a paid dedicated GMod server, these materials are missing.

Is it a bug in SteamCMD ?

The materials are stored in .vpks, they are shipped with all game clients and servers.

So explain me why when I fresh install GMod Dedicated Server on Local machine, there is not these materials ?

EDIT : If you want a video showing you the fresh install then I can do it !

Define “there is not these materials”.

The materials will not be in the materials/ folder.

“These materials” refers to some materials I have in singleplayer but not in server, here is one of these : “materials/models/props_lab/warp_sheet”. They are located in the “materials/models/props_lab/” folder.

I’ll upload a video just wait…

[editline]28th March 2015[/editline]

Finaly, forget about the video Sony Vegas is completely crashed…

As I said, the default materials from HL2 and GMod are stored in the .vpk files, which are shipped with each server and client copy.

So I have the files you’re showing to me.

But these files aren’t mounted on the Dedicated Server

And what makes you think that?

The fact that you can’t see them in game and you can’t past them using AdvDupe…

[editline]28th March 2015[/editline]

Wow Vegas Pro seams to want to render the video I done using NVIDIA ShadowPlay.

[editline]28th March 2015[/editline]

So the video is done however you’ll not be able to read any text sorry, but you’ll be able to see the problem.

That’s caused by running the game in DX8 mode.

I haven’t Direct X 8 on my computer, so it can’t run on the direct x 8. I uninstalled that Direct X 8.

[editline]28th March 2015[/editline]

Here is the video : https://www.youtube.com/watch?v=hcOdJe_G1Wk&feature=youtu.be

Make a picture of this window:

Here is the screen you asked me :

http://www.sldt-team.net/image1.png

Ok, I see the problem.

An addon that adds all those custom materials to your material tool is not installed on your server.

And what is that addon ?

All servers I can come in have the materials that are missing on my server.

How should I know? Compare the addons? Remove addons one by one before the materials disappear from your single player?

I think it may be one of the wiremod/adv dupe addons.

I have AdvDupe 2 and Wiremod already so it’s not that…

Keep searching then.