Materials Not Showing Up on Compiled Model.

I’ve been attempting to compile a model as a test (just the fo4 mannequin), and have run into some difficulties, the dreaded purple and black checkers, the .VTFs are all named the same as the materials were when I added them to the model, so I’m not quite sure what exactly is going wrong, if someone could take a look at it and tell me what It’d be greatly appreciated.

.Zip Archive: https://www.dropbox.com/s/ioq42gz4q586fps/Model.zip?dl=0

“Fin” is the compiled files in case those help.

In the model viewer it’s normal not to have a texture, did you remember to put the materials in the “materials” folder of your garry’s mod? In game it will use that as reference, even if it was compiled with the materials present in another folder.

I was using SFM, but checked in Gmod and the result is still the same, in HLMV it says “no VTFs found”, but I’m not sure why it’s saying that because they should be set up correctly.

I just checked the files, could it be that you forgot to name the material of your model as the same of the VMT? As seen here:

It also could be that you didn’t put the VMT and VTF in a “materials” folder, since that’s where they’re found.

They should be named the same as the materials (as seen below) unless I’ve completely fucked up somewhere, and the textures were in a “materials” folder, expet I moved them out to make the .rar easier to navigate.

If none worked then I say go to the extreme, rename the materials and make sure everything in the path is correct, that’s what I’d do, it’s possible that maybe it’s misspelled, if it says “no VTFs found” then it means that the material names are correct but the VMT aren’t, still, it’s better to be 100% sure.

In Blender, you should give the material a proper name like base & body. Material.002 & Material.005 is still considered as one file.

Give $cdmaterials a proper path for the materials folder.

Remove $translucent from the .vmt

Download:
https://mega.nz/#!DkhGTLLL!9Qlw15NIQskXEvMykmobv07DAThXjBISAnsl5l7XgXU
https://www.mediafire.com/file/6q52oj3w41x4a6f/Redcoat893.zip

Thanks a bunch mate! I’ll keep that in mind.