May I get some help with my copy of Garry's Mod please?

I purchased Garry’s Mod for my Half-Life 2 over Steam yesterday and played it just fine. However when I started to play multiplayer I was crashing a lot from a bug. I cannot remember the bug but after the 4th crash I deleted the local game files and reinstalled. After I did that my Achievements, Singleplayer and Tutorials menu will not open on the main menu. And I cannot get the Q key menu to open, it will just be a small gray box in the upper-left corner.

Could I get some advice or a fix for how to repair my copy? I have also tried deleting my entire Steam folder after uninstalling and reinstalling and the same problem is there, yet for some reason my video settings are still active. Is there perhaps a file I’m not deleting that is keeping this fault?

Thanks to anyone who helps.

Most recent Gmod update broke the menu on x64 systems. We’re waiting on a fix.

I’m currently on an x86 machine. :slight_smile:

It worked just fine until I deleted the file and reinstalled. Until then it worked fine.