ME2 Inferno Armor Crashing when Compiled w/ Animations

I’ve tried compiling S-Low’s ME2 Inferno Armour model with hl2 citizen animations- which seemed to work until spawning ingame in which the model wouldn’t appear except it’s shadow- then an instant crash to desktop. This happens everytime… Doesn’t show up in sdk model viewer either…

I have no idea what’s causing it- so I’m wondering if anyone else can do a quick compile with same animations for me and see if I’m being dumb or something universally wrong with the model when trying to compile.

Download for model is here:
http://filesmelt.com/dl/S-LoW_-_Inferno_Armor.7z

http://filesmelt.com/dl/Derp3.jpg

heeeeelp plz.

[IMG_THUMB]http://uppix.net/4/e/7/a24e8bf92f42caf59bd8f104a9a89.jpg[/IMG_THUMB]

Here, 'cause I’m a nice guy :3:

I think you need the css fix animations

Ok i’ve had a go at compiling it with the anims (as I was going to at some point anyway) and I am having the same problem, however I have managed to compile the helmet as a prop perfectly, which means the model and textures are working fine, so i’m not sure whats going on with it ~.~ (I used cs_fix.mdl incase anyone asks).

Edit: Also the compiler shows no errors on compile. And i’ve tried compiling it without the anims and it made no difference. Also it’s not the collision model as i’ve tried compiling it as a prop and as an effect and it makes no difference.

Edit2: Well i’ve tried everything and by all accounts it should be working, everything shows up in HLMV as normal… except the model (and the collision and such), the compiler shows no errors, the model works if I edit it in Milkshape (but not if I export it as is). WHAT THE HELL @.@

Edit3: Well the helmet works (except for the glass not sure whats wrong with the collision model but I managed to shoot eric through the helmet >.<)

[img_thumb]http://0mcfbq.bay.livefilestore.com/y1pMv8h7PCjh5RG6mOndxkrBK2nDlNZN4kcCNOMDCtjRNyd4Hi9UhQqXy73nO6BcCYMMQlcBrIFIa8e9bU5tpBkZzqkvxx2b8na/Inferno%20Armour%20Helmet.jpg?psid=1[/img_thumb]

I had the same problem with the ported “Collector Armour” one too.

In the end I gave up on it.

Ok your not gonna believe this, but I removed the entire model, replaced it with a cube and exported it and the same problem happens, so it seems anything made in the same space as the model used to exist in, also wont work now ¬.¬

Edit: Ha got it working, for some reason putting $origin 0 0 0 fixed it.

Edit2:

[img_thumb]http://0mcfbq.bay.livefilestore.com/y1pjyGG9g3Kd1LH4v9IJ0pyZQG2Y7bYOcFBhq5YDE_5hs7rM6vZY02gpmjtw4oDKhQw4fWhL48LQZoU9D6YlPN8d8uM6HHHpMDf/ME2%20Inferno%20Armour%20Player.jpg?psid=1[/img_thumb]

Edit3:

That armour (along with the dragon one) already has NPC anims, but i’ll add player anims later on if I can ^^

Wow.

I’m happy it wasn’t me being dumb at least. :v

Sent you a PM.

http://www.garrysmod.org/img/?t=dll&id=109192

There you are ^^ Release Thread

Awesome.

Thanks for your help :smiley: