Menu Problems

For some reason, every time I open a menu over a new menu, it does this (also, when I join a server, the server menu doesn’t disappear when I join). Also, instead of blood and various other effect things, I see wire-boxes flying out of people. Yes I have tried reinstalling GMod (Deleting the directory and everything) and reinstalling it, which didn’t work. And no, I do not have a pirated version of GMod. It worked just fine before the TF2 update and now it does all this.:

http://img200.imageshack.us/img200/4823/wtfgmod.jpg

No one has replyed to this in 5 hours?

I dont know ive have had a hacker send me to HELL on gmod

dont really feel like explainng it

I have the same exact problem. The only things that bother me about it is the underwater part and the Q Menu sometimes transparent in some places.

No idea why this is happening, but yeah it started after the whole TF2 update thing.

I have been thinking it might be some screw up having to do with computer specs since few people are having this issue and even deleting+re downloading gmod isn’t working.

I am running:
OS: Vista home premium SP1 64 bit
CPU: i7 920
GPU: Radeon HD4850x2
Ram: 3gb

omg same problem here! Heres what I got:

*I shoot npcs and lined squares/boxes come out of them.
*flames are invisible
*windows in gmod are overlapping each other
Does anyone know how to fix this?

have you got TF2 installed??
I just uninstalled it and now my menu has changed try that if u have it installed.

I tried unmounting TF2, uninstalling TF2, deleting the entire TF folder, didn’t do anything for gmod. Help? D:

Edit:
FOUND IT!

I was determined to find the post that someone said had the launch option to fix this.

http://www.facepunch.com/showthread.php?t=743091

Went through each page until I found it on the bottom of the 7th page. That thread should be stickied.

For anyone too lazy to look at a thread, add -dxlevel 90 in the launch option. Yes 90, not 9.

Since TF2 had no effect on my gmod, I am going to install it again :smiley: TF2 is a good game. Not sure if the -dxlevel 90 will fix others who had this problem BECAUSE of TF2, but for those who’s TF2 is not effecting Gmod, it should work even after reinstalling TF2.

I forced my game into that DirectX for fun. It looked weird.

dxlevel 90 fixed the problem. Thank You