Mesh Opacity Issue

Hi guys, i have a issue with opacity maps on 3ds max, i’ll be glad if you could point me some solutions.

First of all i want to make sure that i’m doing the opacity map corretly here’s a pic:

http://imageshack.com/a/img7/333/j8l5.png

And my issue is that when i apply that same opacity map to a diffuse map on material editor on max i get this:

http://imageshack.com/a/img801/8350/fa4e.png

(This is a xnalara meshmod)

I’m trying to convert her to gmod, but if i use the raw model from xnalara that is like this:

http://imageshack.com/a/img17/2442/yk3h.png

I fail to export the model in smd format with this error:

Processing Scene…
Writing 12 Node(s)…

  • “inner1nPart!”
  • “inner!”
  • “body11nPart!”
  • “body1!2nPart!”
  • “body1!!3nPart!”
  • “body1!!!”
  • “body21nPart!”
  • “body2!”
  • “eye”
  • “hair”
  • “Object01”
  • “hair01”

Writing Animation…

  • Exporting single reference frame for 12 node(s)

Writing Meshes…

  • “inner1nPart!”

  • “inner!”

  • “body11nPart!”

  • “body1!2nPart!”

  • “body1!!3nPart!”

  • “body1!!!”

  • “body21nPart!”

  • “body2!”

  • “eye”

  • “hair”
    WARNING: Material “Material #34” does not appear to have a Bitmap type diffuse texture. Skipping mesh.

  • “Object01”

  • “hair01”
    WARNING: Material “Material #34” does not appear to have a Bitmap type diffuse texture. Skipping mesh.

Done!

I got these errors just recently and i didn’t change a damn thing on 3ds max, so if you guys could tell me what i’m doing wrong with the opacity or/and help me fix the smd exporter issue i would be grateful, thanks and sorry for anything.

a) it doesn’t have to be transparent in 3dsmax in order for it to work fine in gmod
b) in order to get it transparent in 3dsmax, you need to drag the opacity map into the opacity map slot on the hair material.

a)Does it have a specific .vmt command to set oppacity?
b)But I did that! I placed the oppacity map on the opacity slot on maps under the parent material.

You can use “$translucent” “1” for proper transparency. The only con is that it doesn’t seem to like overlaying over itself, so you make need to use “alphatest” “1” instead which only supports 100% or 0% opacity. In other words, it’ll reduce the quality by a shitload.

It’s working fine in max. You don’t need to worry about that anymore really.

And i could use “alphatestreference” “0.1” together with “alphatest” “1” to make it less “blocky” correct?

You could probably tweak it so it looks a little nicer, but it’s not really a large upgrade. Depending on the settings you use, it might look worse.

The problem with alphatest is that it recognises no middle values. Basically anything under 128gray will be transparent and everything above will be opaque. Much better to compile with $mostlyopaque and use $translucent as far as hair is concerned.

As to max - if you’re using the same texture (RGB for diffuse and A for opacity) you need to set it to no alpha in the diffuse and to monochannel alpha output on the opacity map.

For source, the easiest thing is to just duplicate the hair mesh, assign it a different material, and that duplicate has a copy of the vmt with $translucent instead of $alphatest. That way you have the soft edges of translucent and the opacity of alphatest, and since they’re the exact same mesh with technically the same texture, you don’t see the z-fighting.

If you want to do it proper and conserve tris, you split the mesh up into pieces, where only the edges have the translucent version, and export it as a single mesh. That is time consuming though, and generally speaking, source today can handle the extra mesh. Besides, you’re still using two textures which is the real bottleneck.

Could you explain that on a more noob friendly way? XD

But when i get her to gmod with those tweaks with the .vmt her hair will be fine then? because that blocky hair would be awful for posing don’t you agree?