Messed up bones when importing custom model into SFM

For the past day I’ve been trying to get a model I downloaded off Gamebanana to work in SFM. Almost everything worked perfectly, except for some weird problems with the initial bone placement:

Primarily the hips and feet are messed up, although something seems wrong with the arms as well once one zooms in further. Strangely, the idle sequence is messed up, but the preview for some other sequences, including run_upper_pistol, looks fine. When I try to apply the sequence to the model however, nothing happens and the model stays messed up.
The model I used (http://gamebanana.com/models/3669) is provided in multiple formats including .smd, so I created VFTs/VMTs, decompiled a CS:GO terrorist model with Crowbar (although the Gamebanana model is from Counter Strike Online 2 - I assumed this should work, as both use the same bones, as far as I know), and modified its .qc file to work with the downloaded model, then I compiled a new model and everything worked with no warnings. SFM however complains about the absence of facial animation models:


 "CAnimationSetEditor::CreateAnimationSetForModel: model has no facial animation model models/extra_kreddit_models/leet_cso2.mdl"

… but I guess this isn’t very relevant to my problem.

My .qc file looks like this: http://pastebin.com/9By8YMSF
(I removed the ragdoll and collision model parts the CS:GO model had since I only intend to use the model in SFM anyway)

I suppose it has something to do with my .qc not being compatible with a model from another game, especially the part where I use CS:GO animations, but I don’t know what I have to change for the bones to be in order again, so any help would be appreciated!

I solved the problem by simply changing the sequence to a standard idle one instead of using the CS:GO one:



$Sequence "testIdle" {
	"leet_cso2_testIdle.smd"
	fadein 0.2
	fadeout 0.2
	fps 30
}


becomes


$sequence idle "leet_cso2.smd"

. Maybe it helps someone!