Messed up textures, missing settings, What do?

Last night I was getting a bit fed up with my computers low FPS with newer games, so since I use AMD I used its Catalyst Center to change graphics and certain settings for maximum performance, and it worked fine. So then I decided to play a bit of Garry’s Mod and everything just went to shit, Models don’t produce shadows when lamps are pointed in their direction, when underwater the water texture is replaced with the pink and black textures (I DO NOT have any add-ons that change water textures) Water has a very white tint from above, and settings are missing from the graphics setting (Shadow settings). I tried changing back the settings from the Catalyst Center, that didn’t work, Verified the games cache, didn’t work, restarted my computer, didn’t work, reinstalled the game, didn’t work, tried restoring drivers/updating drivers, didn’t work. And a system restore wont work as the ONLY restore point is from today, the incident happened last night. What do?