Microphone Issues

Hello, im trying to get my microphone to work ingame

it works on teamspeak, skype and everything else, but when i talk ingame its just static

i tried to record my vioce using this page and all i hear is static
https://dl.dropboxusercontent.com/u/99106620/USpeak%20Test/USpeakTest.html

my microphone is set as default communication device in sound manager

any ideas?

bump, plz help

Hit F1 and check if your microphone is the one chosen by the game. If it is, go to options and turn music volume all the way up. That seems to help for me.

tried that, didnt make any difference

May I ask what Microphone it is? Because I have one that did that and it never worked again.

Mind giving this a try and see if it works? (Hit the Start recording button, talk, and hit the Stop recording button to listen to your own voice).
It’s the same voice chat framework used in Rust, so if there’s a problem with the voice chat itself this should let me know.

https://dl.dropboxusercontent.com/u/99106620/USpeak%20Test/USpeakTest.html

i tried this and all i hear is static, when i hit f1 ingame its shows my Microphone selected Realtek High Definition Audio and im using windows 8.1

its strange because i tested it in teamspeak with my friends and it works without a problem, its just in Rust and USpeakTest that i just hear static noise

sigh, by the time it takes me to type in chat im friendly, im already dead, i wish my mic would work in this game

Sigh, lets take it back to basics.

  1. When you press f1 does it list your active recording device? You could have multiple and the wrong one might be set as default.

  2. Are you pressing v for voice chat?

  3. You know it’s only proximity voice chat and not entire server wide right?

  1. Yes when i press F1, it lists my active recording device, Microphone (Realtek High Definition Audio)
    (i have check my sound properties and my microphone is set as default device and default communication device)

  2. Yes i am pressing V for voice Chat, and my friend confirmed he just hears static noise

  3. Yes i know its only Proximity voice chat, (i.e. i have to be standing next to the person for them to hear me)

Have you checked that Teamspeak is using the same microphone? Also try a test recording in something like Audacity.

yes teamspeak is using the same microphone, its the only microphone i have

You never know, something might register itself as a microphone even if it really isn’t. For instance, I’ve got one single microphone, but Windows actually recognizes three:

Microphone (Plantronics GameCom 780) <-- My real microphone
Microphone (Realtek High Definition Audio) <-- Not my microphone
Line In (Realtek High Definition Audio) <-- Also not my microphone

ok so in my audio recording properties i have
FrontMic (Realtek High Definition Audio) (Disabled)
Microphone (Realtek High Definition Audio) <---- My Mic (Default Device/Default Communication Device)
CD Audio (Realtek High Definition Audio) (Disabled)
Line In (Realtek High Definition Audio) (Disabled, unplugged)
Stereo Mix (Realtek High Definition Audio) (Disabled)

u thinking one of these could be set as the microphone? how would i go about changing it or finding out?

EDIT: i just checked teamspeak and it is using Microphone (Realtek High Definition Audio)
and on https://dl.dropboxusercontent.com/u/99106620/USpeak%20Test/USpeakTest.html when i try to test and i just hear static it says
Using Microphone: Microphone (Realtek High Definition Audio)

im still having no luck with this issue

I have the same issue… although when i use the link to test the mic i kinda hear myself… but with a very weak volume.

I had the same issue. Rust was picking up my other mic that I used to use. I had to disconnect it completely so it would register my new mic.