Mismatch: Effects/propspawn/init.lua

http://img10.imageshack.us/img10/9878/22378073.png

I’m getting this error because I have a version that differs from the servers right? Anyway of fixing it?

Delete your cache and lua folders, and make sure cl_downloadfilter is set to all