Missing crosshairs

Hey i was playing gmod and i noticed my crosshairs were missing and im really frustrated. Does anyone know why they are missing and if so how can I fix it? I already tried putting in the console command “crosshair 1” like i saw on a different thread and it didnt work. Can someone please help?

If its rp is rp_crosshairs 1 I think. if your in a rp server they are usally disabled

Well i only play single player so its not because of the server cause i never turned it off

No use cl_crosshairs 1 or get a crosshair texture replace LUA tool.

I have the same issue. No commands work for me. Mine came about gradually though. It first only dissapeared if I crouched, later if I aimed at certain walls, and now its dissapeared all together

This is like happening to me, my suggestion download a custom crosshair it worked for me

Some weapons such as physgun are crosshairless, and my hud icons are replaced with hud icons for medieval weapons, but I don’t remember installing any contents and I’ve searched through garrysmod and other source game folders but I found nothing.