Missing Executable ... I feel like I've tried every solution

So, I go to launch Garry’s Mod for the first time since HL2/Ep1/Ep2/CSS were converted to Steampipe. Lo and behold, my game suddenly tells me I’m missing an executable.

I click on the link it indicates, which takes me here. I follow those instructions and try again. No luck.

I try a Google search and find a bunch of different solutions, all of which did not work. I have tried the following already (in no particular order):

  • Verify the integrity of the game cache (multiple times): Always says it’s fine
  • Deleted the appcache directory (as indicated at the above URL; also multiple times): No change
  • Uninstalled Garry’s Mod completely AND deleted any remaining Garry’s Mod related folders from my Steam directory AND did a fresh install to the default Steam directory: No change
  • Uninstalled Garry’s Mod completely and installed it again to a DIFFERENT directory and hard drive: No change
  • Deleted clientregistry.blob (three times): No change
  • Validated Half-Life 2, Episode 1, Episode 2, CS: Source. CS: Source DID need to be converted to Steampipe still but even afterwards there was: No change
  • Ran HL2, Ep1, Ep2, CSS to see if that was the issue: No change
  • Validated Source SDK Base 2006/2007 (multiple times): No change
  • Uninstalled and reinstalled Source SDK Base 2006/2007: No change
  • Deleted the appmanifest_4000 which relates to Garry’s Mod from the steamapps folder.
  • Put my steamapps folder under the exclusion list for Windows Defender (my anti-virus): No change
  • Unsubscribed to every Steam Workshop item I was subscribed to for the game: No change
  • Opted out of the Steam client beta: No change
  • Moved hl2.exe to the Steam\steamapps\common\GarrysMod folder (since it is obviously NOT PRESENT in the current directory): New error! It says “Failed to load the launcher DLL: The specified module could not be found.”
    – For the hell of it, I just did it again while typing this up and it still gives me the DLL error when attempting to launch.

I seriously have no idea what more I could possibly try.

A picture of the only Garry’s Mod directory I have in my Steam folders. This is the same directory that opens when I go to Properties > Local Files (tab) > Browse local files…:

I have 38 hours in the game. I’ve played it before on my current setup without any issue. This happened sometime between when I last played (pre-HL2 steampipe conversion) and yesterday when I went to go run it to get the cards for the game.

Generic System Specs:
Windows 8 Pro - 64bit
i5 2500K
GTX 560Ti
8GB RAM
Installed (along with my other games) to my E drive (secondary HDD) but also did not work when I tried installing to my G drive (an external USB 3.0 drive)

Is HL2 in the common folder as well? If it’s not, that’s likely a problem.

[editline]18th July 2013[/editline]

I had this issue with CSCZ, I had to completely uninstall Half-Life and its goldsrc games and then reinstall so they’d be in the common folder.

I do have a Half-Life 2 folder under common, which contains the following:

Edit: I’m going to be really bummed if I go to uninstall every Source Engine game I have, reinstall them, and then see it still doesn’t work. I’ll hold off on that unless there really is no other suggestion.

Sorry, it’s the only solution I know that should work.

:frowning:

So what’s the order of business here? Uninstall everything, INCLUDING Garry’s Mod, reinstall all other Source Engine titles, and THEN reinstall Garry’s Mod AFTER I’ve installed and ran the other Source titles?

Try reinstalling without Steam Cloud enabled for Garry’s Mod, see if that does anything.

EDIT: I said this because he didn’t specify if he had turned off Steam Cloud when doing reinstalls.

You only need HL2 to start GMod. But essentially, yes.

I’ll try that right now before I remove the Source titles and try that method.

Well, this is going to be fun (if it comes to it).

EDIT: Unfortunately, the Steam Cloud disabling did not work. I also tried changing content servers and validating again… No dice.

Looks like I’m going to uninstall my Source games and try that…

Well damn it.

I uninstalled HL2, Ep1, Ep2, CSS and even the Source SDK Base 2006/2007. I removed all HL2 folders from my Steam directory.

I reinstalled HL2. I ran HL2. I played HL2 for about ten minutes.

I reinstall GMod. I try to run GMod. Still has a missing executable.

I’m seriously about to pull my hair out now.

What virus/malaware protection programs do you use by chance?

Windows Defender (it’s simply the Windows 8 name for MSE).

I added E:\Steam\steamapps
and E:\Steam\steamapps\common\GarrysMod

to the Defender exclusion locations.

Edit: I suppose I can try turning off real-time protection completely for the brief period while I re-download the game … again.

Edit 2: Nothing else has worked. I tried disabling my anti-virus completely and it didn’t work. I changed content servers, I made sure the files weren’t read-only, I ran Steam as Admin, etc. Nothing. Has. Worked.

I asked someone to click on “Browse Local Files” for their Garry’s Mod install that works for them. It takes them to steamapps heir user name\garrysmod while mine takes me to steamapps\common\GarrysMod and contains ONLY what you see in the image in the opening post (minus hl2.exe since I didn’t bother to try moving it back over after the latest re-install).

I don’t even HAVE a Garry’s Mod folder under my username\ directory and he doesn’t have a GarrysMod folder under common! What in the hell is going on here?

I got this from a google search, but try deleting the clientregistry.blob file in the Steam folder.

EDIT: Turns out I’m as blind as a bat.

I did that (it’s in the list in the OP) three times and it didn’t do anything.

Get avast.

Okay back on topic - Are you sure you ENTIRELY deleted your Garry’s mod upon re-install. Delete local content and delete the folder. After re-install verify it to see if it can find any missing files…In this case the executable.

You say in the OP that you deleted the appmanifest_4000.acf file and it downloaded it back, have you tried opening the appmanifest_4000.acf file and checking the directories?

I had Avast and it was terrible. I think the anti-virus can be ruled out anyway given that I completely and globally disabled real-time protections while testing a good deal of the above in this thread. =/ (EDIT: sonny236, if you want to rate this dumb because I dislike Avast, I’ll offer more on that. I not only disabled real-time protections on multiple occasions with Defender, but I also added the aforementioned Steam directories to the exclusion list. Beyond that, I even looked under “Quarantined items” and “All detected items” and there was not a single reference to Garry’s Mod detected. If it was Defender picking it up, it would appear there, probably multiple times now for as many times that I’ve attempted to re-install this game in the past few days. Sorry for not wanting to revert back to an inferior anti-virus, one that I used for years prior and came to dislike due to its ineffectiveness at doing the one job that was required of it.)

But yes, I did delete all instances of it previously. I can always try that again, but first…

Here is what the current appmanifest_4000.acf says:

Does this look right? Like I said before, that is the only Garry’s Mod folder I can see within Steam. My friend, whose Garry’s Mod works just fine for him has NOTHING under the “Common” directory. His game folder is under his username\garrysmod and working fine.

I’m in the same boat. Tried everything he has tried. When I download Garry’s Mod from Steam, the steamapps/downloads/4000 folder doesn’t list hl2.exe as being downloaded and it’s missing a ton of DLL files from the ‘bin’ directory. Manually copying hl2.exe in to the directory causes a missing DLL error. If I copy over HL2’s bin folder then it gives me a missing materials error (background01_widescreen.vtf I think).

I don’t know if it’s comforting or worrying that I’m not alone in this issue right now.

Yeah, it makes zero sense. My only thought is that the files we’re receiving from Steam aren’t the complete set. I’m going to have a friend send me his copy of gmod and see if that works.

Edit: Got a copy of the steamapps/common/GarrysMod directory and copied it over. Worked fine. I guess that’s the only solution.

That seriously worked? What the hell… Why is this even doing it in the first place and apparently only for a few people?