Missing file

So I created this new map, and now when I want to compile it for the first time Hammer says it can’t find the maps BSP. Well no duh, hammer is supposed to create the BSP after I compile it right?

"The Command failed. Windows reported the error: “The System cannot find the file specified.”

Try Interloper’s Error Log. Copy and paste your compile log into this, by hitting the Copy to Clipboard, then pasting it in there and hitting find errors.

Ah, fixed it. For some reason it is wanting me to directly save the vmf into the maps folder of the game I am mapping for. Which is weird because I have never have had to do that before. =/

[editline]04:52AM[/editline]

Nevermind, I get no error but it still doesn’t create the BSP.



** Executing...
** Command: "c:\program files\steam\steamapps
ame\sourcesdk\bin\ep1\bin\vbsp.exe"
** Parameters: -game "c:\program files\steam\steamapps
ame\half-life 2\hl2" "C:\Program Files\Steam\SteamApps
ame\half-life 2\hl2\maps\mansion"

Valve Software - vbsp.exe (Dec 11 2006)
2 threads
materialPath: c:\program files\steam\steamapps
ame\half-life 2\hl2\materials
Loading C:\Program Files\Steam\SteamApps
ame\half-life 2\hl2\maps\mansion.vmf
fixing up env_cubemap materials on brush sides...
Creating default cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
Run buildcubemaps in the engine to get the correct cube maps.

No such variable "$hdrbasetexture" for material "skybox/sky_day01_01rt"
Can't load skybox file skybox/sky_day01_01 to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (16 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10

** Executing...
** Command: "c:\program files\steam\steamapps
ame\sourcesdk\bin\ep1\bin\vvis.exe"
** Parameters: -game "c:\program files\steam\steamapps
ame\half-life 2\hl2" "C:\Program Files\Steam\SteamApps
ame\half-life 2\hl2\maps\mansion"

Valve Software - vvis.exe (Nov  8 2007)
2 threads
reading c:\program files\steam\steamapps
ame\half-life 2\hl2\maps\mansion.bsp
Error opening c:\program files\steam\steamapps
ame\half-life 2\hl2\maps\mansion.bsp

** Executing...
** Command: "c:\program files\steam\steamapps
ame\sourcesdk\bin\ep1\bin\vrad.exe"
** Parameters:  -game "c:\program files\steam\steamapps
ame\half-life 2\hl2" "C:\Program Files\Steam\SteamApps
ame\half-life 2\hl2\maps\mansion"

Valve Software - vrad.exe SSE (Nov  8 2007)
----- Radiosity Simulator ----
2 threads
[Reading texlights from 'lights.rad']
[45 texlights parsed from 'lights.rad']

Loading c:\program files\steam\steamapps
ame\half-life 2\hl2\maps\mansion.bsp
Error opening c:\program files\steam\steamapps
ame\half-life 2\hl2\maps\mansion.bsp

** Executing...
** Command: Copy File
** Parameters: "C:\Program Files\Steam\SteamApps
ame\half-life 2\hl2\maps\mansion.bsp" "c:\program files\steam\steamapps
ame\half-life 2\hl2\maps\mansion.bsp"



I guess no one saw my edit. Since it wasn’t a new post. Theres the log.

It doesn’t work because of an error. Run it through this: http://www.interlopers.net/errors

If that doesn’t work try checking for problems (If I remember correct it’s alt+P in hammer).

Interlopers is down for the moment, Ill check for problems in hammer. I forgot to do that.

[editline]10:06PM[/editline]

Fixing the small problems in the map didn’t do anything.

sigh interlopers here I come.

Which game are you testing your map in?

Making it for Half-Life 2, testing it for Half Life 2. The reason it can’t find the BSP it didn’t even create the BSP when I compiled it. Hammer does fine on everything else. I have started the same project before but had different errors. Months later I try again brand new graph, and get this error.

[editline]11:29PM[/editline]

Hey is it just me or is the Interlopers site down?

Just wondering. If it is just me I need to fix whatever it is.

Usually this error happens to me when there is an invalid brush. Try saving, closng hammer, then reopening. It goes “# invalid brushes were removed while opening!” then they are gone. But if it doesn’t than this could be something worse.

If you want to send me the .vmf, that’s cool. If you don’t… Well, that’s okay too.

Interpoopers is up for me!

Don’t take that offensively, I love the site.