Missing GUI (Post your graphics card here)

I would assume this would be easier for the developers to fix the missing GUI issues. If you’re experiencing the issue, you should post your graphics card here and possibly what version of drivers you have.

Get latest drivers here:
ATI: http://support.amd.com/us/gpudownload/Pages/index.aspx
Nvidia: http://www.nvidia.com/Download/Scan.aspx?lang=en-us
Intel: https://downloadcenter.intel.com/default.aspx (apparently Intel graphics does not work with Rust on Windows, so far)

How do I tell what graphics card I have?
dxdiag - Type “Dxdiag” in the start menu and check under the “Display” tab. Sometimes it only shows series (showed exact card for me)

Device Manager - Open Device Manager, then open the Display Adapters drop down. It’ll show your exact card.

Programs - There are multiple different programs that can tell you what hardware your computer is currently running, however I found Speccy to be the most user friendly.
You can download Speccy here: http://www.filehippo.com/download_speccy (hit the “Download lastest version” button in the right corner)

Who is/may be affected?
The issue seems to affect mainly laptop users, however I’ve seen this affect PC’s too.
I will update the list below as people post their graphics cards, if they’re experiencing the problem(s).

Affected List:
Nvidia GTX 780m
Nvidia GTX 660M
Nvidia GTX 635m
Intel HD 3000
Intel HD 4600
Internal Intel® HD Graphics Family 1696MB
ATI Mobility Radeon HD5730
ATI Mobility Radeon HD6550D
ATI Mobility Radeon HD6650

Possible fixes:

Thanks:
FossilAmoeba for dxdiag alternative
shadowndacorner for device manager alternative
StarMcBound and InsaneParrot on Intel graphics

I’m in no way shape or form a developer, however a few of my friends have experienced this problem and I would love for everyone to have the ability to see the GUI, and listing graphics cards that are experiencing the problem may help the developers resolve this issue :slight_smile:

Great initiative :slight_smile:
If you don’t want to download something, you can type “Dxdiag” in the start menu and check under the “Display” tab. But this won’t show the exact card, only the series it’s in, so your solution is better! :slight_smile:

If you don’t want to install anything and are running Windows, do a search in the start menu for Device Manager, then open the Display Adapters drop down. It’ll show your exact card rather than just the series.

You forgot Intel’s website.

Was going to suggest that, but only shows the GPU’s series for me, oh well :slight_smile:

It’s been said many times that integrated graphics do not work with Rust, haven’t seen a single person get it to work correctly.

Updated OP with suggestions. and Intel not working?

Great thread :slight_smile:

Intel HD 3000

Geforce GTX 635m has the issue aswell

Internal Intel® HD Graphics Family 1696MB as well.

My GTX 660M worked for a few days then I updated the drivers and it stopped working.

Loisteres do you know which drivers you had before you updated? if so we can downgrade and see if it fixes it.

Burrd, I’m not sure honestly man :confused: I’ll look into it though. But I did try to do a system restore before I did update it and it just messed things up and didn’t work. So I really don’t know what’s going on. My desktop doesn’t work either cause the HUD is missing, not sure what the GPU is but I know it’s AMD and I tried updating the drivers but it wont let me since I am using the up to date one.

Edit: My desktop is a Radeon HD 5xxx PCIe, not sure what the exact model is atm.

Try checking it out in the Device Manager (if you didn’t already) or download Speccy if you feel like it :).
And regarding the driver rollback, try:
1: Opening the Device Manager
2: Click “Display Adapters”
3: Double click on your Nvidia card (GTX 660M)
4: Now select the “Driver” tab
5: Now click on “Roll Back Driver”

Hopefully that will solve that problem :slight_smile:

My brother got his GUI fixed last night, when he gets on later ill get him to post details. he has integrated and discreet GPUs in his Alienware but until last night had the missing GUI issue.

LoooL you gubs know how to fix? xD

bump to first plage

Dude. I fucking love you. It worked. Be my best friend for life. <3

loisteres now which drivers do you have installed? aka which did they revert to?